(4.11 Preview 4) - Character Blueprint Compile Crash

When I compile my player character blueprint, I get a hard crash. This is something that does not happen in 4.10.2. I’m not sure if it’s a “real” bug or something I just need to fix or change. I have not been able to track the reason for the crash. I’m posting this log entry here if someone can maybe tell me what this means exactly. It kinda gives some info but I don’t know how to track that info in my actual blueprint. Also don’t know if it’s enough info for anyone to see the real problem. This isn’t something I can reproduce either. I don’t know what it is yet. I decided to post this just in case maybe someone can give me more info on how to track this from the log info, or if it could be an actual bug.

[2016.01.29-08.14.06:714][487]LogStats:                SubmitErrorReport -  0.000 s
[2016.01.29-08.14.06:924][487]LogStats:                    SendNewReport -  0.209 s
[2016.01.29-08.14.06:924][487]LogStats:             FDebug::EnsureFailed -  1.054 s
[2016.01.29-08.14.06:924][487]LogOutputDevice:Warning: 

Script Stack:
TRASHCLASS_Ninja_Anim_BP_122.Function_1012

[2016.01.29-08.14.06:925][487]LogWindows:Error: Windows GetLastError: The operation completed successfully. (0)
[2016.01.29-08.14.07:189][487]LogCrashTracker: 


[2016.01.29-08.14.07:190][487]LogCrashTracker: 


[2016.01.29-08.14.07:190][487]LogWindows:Error: === Critical error: ===
Assertion failed: ((UObject*)ContainerPtr)->IsA((UClass*)GetOuter()) [File:D:\BuildFarm\buildmachine_++UE4+Release-4.11\Engine\Source\Runtime\CoreUObject\Public\UObject\UnrealType.h] [Line: 311] 
'Ninja_Anim_BP_C_2' is of class 'Ninja_Anim_BP_C' however property 'FloatProperty_1232' belongs to class 'TRASHCLASS_Ninja_Anim_BP_122'




[2016.01.29-08.14.07:228][487]LogExit: Executing StaticShutdownAfterError
[2016.01.29-08.14.07:234][487]LogPhysics:Warning: PHYSX: ..\..\PhysX\src\NpScene.cpp (2946) 8 : PxScene::unlockWrite() called without matching call to PxScene::lockWrite(), behaviour will be undefined.
[2016.01.29-08.14.07:234][487]LogPhysics:Warning: PHYSX: ..\..\PhysX\src\NpScene.cpp (2946) 8 : PxScene::unlockWrite() called without matching call to PxScene::lockWrite(), behaviour will be undefined.
[2016.01.29-08.14.07:234][487]LogPhysics:Warning: PHYSX: ..\..\PhysX\src\NpScene.cpp (2946) 8 : PxScene::unlockWrite() called without matching call to PxScene::lockWrite(), behaviour will be undefined.
[2016.01.29-08.14.07:234][487]LogPhysics:Warning: PHYSX: ..\..\PhysX\src\NpScene.cpp (2946) 8 : PxScene::unlockWrite() called without matching call to PxScene::lockWrite(), behaviour will be undefined.
[2016.01.29-08.14.07:235][487]LogWindows: FPlatformMisc::RequestExit(1)
[2016.01.29-08.14.07:235][487]Log file closed, 01/29/16 10:14:07

HI Obihb,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • What changes were made before this crash began occurring?
  • Can you post your full crash logs here? They are located at \Unreal Projects\PROJECTNAME\saved\logs.
  • What steps can I take to reproduce this on my end?

Thanks for your reply Adam.

Here’s the log file:- Dropbox - File Deleted

The crash is limited to my one project and it’s just the one blueprint from what I’ve tested so far, it’s my player character blueprint. It’s fairly elaborate so I don’t even know where to start to try reproduce the crash.

I did not make any changes. I tried both, opening a copy and migrating the project from 4.10.2, both versions had the same crash. It compiles fine in 4.10.2.

Just to mention again, I can’t reproduce it, I really have no idea what “part” cause the crash and my blueprint is pretty elaborate. I kinda hoped the log will give the clue, I just don’t know how to interpret this error at the bottom of the log. That seems to be telling something, I just don’t know what it means.

Did you try fixing up redirectors on your contents folder? If the actor was moved or renamed before the project was updated and redirectors were present without being cleaned up it can lead to a trashclass, which are the primary errors I am seeing within your logs.

I usually keep redirectors clean, but I went into my 4.10 project now and tried to clean redirectors just to double check and it did nothing. Tried on all possible offending folders starting with the Content folder, just to try it all. There’s no redirectors to clean up.

Is there a way I can track down exactly what this float is mentioned from the log?..

FloatProperty_1518’ belongs to class 'TRASHCLASS_Ninja_Anim_BP_176

I mean, without trial and error. Or do I just have to go by trial and error through everything until I find it?. It looks like it’s actually from my Animation Blueprint, even though that will compile just fine, it’s the Character Blueprint that causes the crash.

I assume this is the trashclass you also mentioned. This is what I was wondering about. That seems specific, but I still don’t have a reference to what it is inside the blueprint. “FloatProperty” can be a hundred things. If I can find it, I can just fix it, if it’s a corrupt node or whatever.

Do you have any circular dependencies or loops in your blueprints?

Do you mean specifically between the character blueprint and the animation blueprint?. I think so yeah. From the animation blueprint I cast to the player so I can get all the values, but I also send notifies from the anim blueprint to the character.

Want to say sorry in advance if I don’t reply soon after this, it’s about 30 past midnight here so this probably my last message for tonight. But if you think there’s a problem there, it gives me some place to focus testing, I’ll do that tomorrow and see . Thanks for all your help so far.

So, I’ve done a lot of trial and error tests now to try find the exact problem and I still don’t know the actual problem, but the only way I can successfully compile my player blueprint, is if I either completely remove any reference to the animation blueprint, or replace it with a brand new one. Using a copy of the old one does not work.

I haven’t tried recreating the animation blueprint with the same functionality, that’ll take way more time and it’s something I want to avoid, so not sure if I did that, if it will also break it in some way, or if that’s the only way to fix the problem.

On my original animation blueprint, I tried cleaning out various variables to see if I can find the problem but all that does is it shifts the problem over to a new variable. For instance, currently the log will mention some Float gives an error, if I kill all Floats, it’ll say some Boolean gives an error, I tried killing all Booleans then it says some Struct gives an error, and I don’t even know what that means, so that’s where I stopped with that.

I can do something similar with the player blueprint. If I kill various variables, it’ll actually work for that one compile attempt, if I then close it and open it and try compile again, it’ll crash again. I’ve cleared my blueprint completely step by step trying to locate the offending node or variable but after cleaning out the whole thing, only then it seems to work, which isn’t useful.

Do you have a sample asset I can take a look at that this is occurring in? I’d be happy to take a look and see if I could see what is going on.

Thanks Adam, I’ve sent you a private message with a link, the message has the same title as this answerhub post.

I’ll mention that I’ve done some further testing, recreating the animation blueprint by copying pieces from the old blueprint and reassigning variables… etc. This did not work. I assume by copying stuff out of the old blueprint, I’m essentially copying the problem.

I’d like to hold off on complete recreation from scratch until I’m sure that is the only way out. It’s quite a job to do that… :slight_smile:

I received the message and have been able to reproduce the crash on my end. I have entered a bug report, UE-26245, to be assessed by the development staff. Unfortunately, I don’t have a good workaround for you at this time that can help to avoid this error outside of completely re-creating the blueprint, avoiding the circular dependency if at all possible.

Thanks Adam.

Just one, I guess two questions, if you don’t mind. Does this mean I can wait for a possible future fix?. I don’t actually mind the crash too much right now, I can keep working on my project, the blueprints do ultimately work.

Is it definitely related to the dependency?. If I remove the notifies completely, which is the only possible circular dependency there, it still crashes. Or is that just because the damage is already done and only a clean blueprint from scratch can fix that?. It’s been setup like that since ver 4.2 or there about. So it’s been working for many versions.

It may not be dependency related, however typically with trashclass errors like the one showing in the logs the culprit is often either a cyclical dependency or an error with redirectors, both of which we looked at during these initial tests. It is entirely possible that something else is causing the error, however, so I wouldn’t rule it out. You certainly can wait for a fix to be implemented, however I unfortunately cannot guarantee a timeframe of if/when that will be.

Ok, I get it, and understand the time frame is unpredictable, not a problem, thanks a lot again for your help. If I do come across something that I can pin point more specific, I’ll post back here,

I have the same problem and the editor crashes when I add an event or function to my character blueprint and try to compile. The crash report mentions TRASHCLASS and the animation blueprint.

A workaround that works for me is to remove all references to animation blueprints from my character blueprint, compile, add any events, compile, then re-set the animation blueprints.

It’s totally infuriating though because I have three animation blueprints and I’m doing a lot of work with my character and animations.

Hi handy_tool_lover,

This has been fixed internally, please keep an eye out for its release in a future build.

Hi Adam,

It seems that 4.11 Preview 6 might have fixed my crash. I’ve done some real quick tests and so far what normally crash, doesn’t crash anymore. Considering before I could not compile my player blueprint without a crash, even with the smallest of changes, not without removing the AnimBlueprint. But now it seems to compile doing various changes while keeping the reference to the AnimBlueprint on there. So I’ll see over the next few days as I work on things, if it crashes at all. The “Fixed List” does not include this, UE-26245, so not sure if there could have been a duplicate entry of the same bug, or if there’s more than one bug with similar consequences.

Would be interesting to know if Preview 6 also fixes the problem for handy_tool_lover, as some sort of confirmation.

Hi Obihb,

This bug report was closed as a duplicate of 26642, which has been fixed internally. It may have made it into the 4.11 P.6 and simply been unlisted, otherwise it should be included in a future release.

Hey Adam…

Thanks. I looked through the list and 26642 is listed. So if this was a duplicate then it is officially fixed in Preview 6… awesome… thank you.

I’m happy to hear it, I didn’t catch it when I looked through so thank you for letting me know!