4.11 packaging ios incorrect bundle identifier

When packaging new or existing ios projects for distribution, UE fails to recognize the bundle identifier explicitly set in the ios package settings. It always defaults to *.YourCompany.ProjectName

4.10 does not have this issue.

To reproduce, simply package a project for distribution and attempt to upload to itunesconnect to recieve error. You can also verify the incorrect bundleid in the plist.


We are looking into this and will respond once we have additional information. Thank you!

Is this a code-based project or a content-only project? Binary or Github?


Happened in both code-based and content-only with Binary Rocket on Mac. Not sure about github or Windows content-only.

To reproduce, simply package a project for distribution, a code sign error occurs.

Even tried creating brand new product and packaging. Same error.

You can also verify it is putting the incorrect bundleid in the packaged plist.


Thanks for providing us with this information. I have packaged projects on the Binary version of the engine for Distribution - iOS. Both 4.11 Preview 4 and 5 provide me with the same error: Error Failed to Code Sign.

After looking into this further, it seems that this issues fix was submitted after preview 5 was released. If you’d like to download our source version of the engine, I would look into getting a version of the engine that’s after CL 2863698.


Thanks - Will try source build now…

How do I verify whether it is after CL 2863698? Does the latest branch of Preview 4.11 work?

You can verify the number by going to Help > About Unreal Editor and you’ll see it say Version: 4.11.0-2858478. Which is lower than the number provided previously.

I verified with the Developer that 2863698 is the CL the fix was included in.


  • The good news is the latest 4.11 branch on gihub now deploys to iOS. The bad news is that the same bundle identifier packaging problems still exists when deploying to tvOS. Can you make sure that the fix is also applied to tvOS platform?

Thanks again for your help

Thanks for letting us know that the latest 4.11 branch on GitHub has allowed you to deploy to iOS. Please keep in mind that tvOS is an experimental feature in 4.11 and it’s not expected to be fully supported in 4.11. We do plan on it being fully supported in a future version of the engine though. With that being said, I have made sure that this issue is being tested and addressed by Engine QA and our Developers.

Thank you!

  • This issue is still occurring for Apple tvOS in the 4.11 release. Just to reiterate - it is impossible to deploy to Apple TV due to this bug.

TVOS is experimental in the 4.11 release. However, you can fix the issue as follows: in UEDeployTVOS.cs (Engine/Source/Programs/UnrealBuildTools/TVOS) replace:

ConfigCacheIni Ini = ConfigCacheIni.CreateConfigCacheIni(UnrealTargetPlatform.IOS, "Engine", bIsUE4Game? null : new DirectoryReference(ProjectDirectory));

(approximately line 47) with:

DirectoryReference DirRef = bIsUE4Game ? (!string.IsNullOrEmpty(UnrealBuildTool.GetRemoteIniPath()) ? new DirectoryReference(UnrealBuildTool.GetRemoteIniPath()) : null) : new DirectoryReference(ProjectDirectory);
ConfigCacheIni Ini = ConfigCacheIni.CreateConfigCacheIni(UnrealTargetPlatform.IOS, "Engine", DirRef);

That will make it so Content-only projects will properly deploy to the Apple TV. Code-based should work fine even without those changes. This will be fixed in 4.12 as TVOS will become a first class platform at that time.