4.11 CSV import fails with no explanation

Every time I try and import a CSV file, no matter what’s in it, I get this error:

Failed to import ‘D:/Projects/Unreal Projects/GamepadKeyboard/Names.csv’. Failed to create asset ‘/Game/GamepadKeyboard/Blueprints/Names’

It never asks what structure to use or what type of file it should be. I’m using Excel 365 and saving the file as .csv. I have data in A1 and a test CSV had this data setup if that helps anyone:

,Age,Gender
Bob,45,Male
Judy,43,Female
Timmy,36,Male

Is there anything that I need to set first in the editor to allow data tables? I can’t import by the Import button, drag and drop or creating a data table then trying to reimport.

Any help would be greatly appreciated.

Have you created the BlueprintFunctionLibrary C++ class and defined the data in a USTRUCT?

Did you remember to leave A1 title blank?

Also make sure no spaces are in the titles including A1.

Are you making sure you are saving as normal .csv and not .csv(mac) or .csv(ms-dos)?

I didn’t think I had to do any C++. I was following a tutorial that showed how to do it in BP. Maybe I missed a step or something. Otherwise, none of those other issues should be a problem. As stated above, it’s not asking for any type of struct so I don’t think it’s even getting that far. I’ve also tried an empty CSV to no avail.

BTW, I create a struct in BP that had the same two column headers for what it’s worth.

Finally got around to trying again today and it worked fine. No idea what was up, I didn’t do anything different. guess this can be closed.

Glad you got it working; sometimes when I have problems with Blueprints I find closing project and Unreal Launcher then loading everything again can solve problem.

Hi, actually there is a proper answer to this issue, which is : .csv cannot be imported into UE4 if they are already opened in another software. To avoid the aforementioned issue you must make sure the document is closed, then import it.

1 Like

Yep, I can vouch for this. Had this exact problem today, finally hit upon it by accident. Kind of annoying that you have to close it in Excel each time you want to reimport.

Just had the same issue, thanks Dinfael.
Logical when you look at it, a file open for write in another applications means you may not have the latest.
Would be nice to have a sensible message like file already opened, as it barfs before it asks you to select the data table import format etc. sign of a poorly written error messages in the unreal engine SDK.

Tripling up to say that this was the error I was having. The instant I closed Excel was the instant I could successfully import the CSV. You rule, Dinfael.

Thanks for that Dinfael, fixed my issue. was driving me nuts :slight_smile:

Thank you. Very weird… surely the engine could create a temporary copy or something to get around this.

yep that was the issue
fu cking unreal

You have to close your Excel =)