Download

4.11 build times & Intermediate build file sizes

Hello.

I am looking at building from source, But I am not sure if the (initial/clean) compile times would put me off it.

So, Could you post you what CPU you use along with the HDD space needed for compilation(along with any other important info) ?
I read a thread saying that he had >43GiB of intermediate build files.

I also read in a old thread (version 4.7/4.8) that the whole engine version will be rebuilt when packaging due to the editor wanting clean builds, Is this still the case?
And with that, I read something about building a Rocket version that works the same as the launcher version; Is this true?

Thanks in advance.

Bump.

What about any recent version?

I’ve got an i7 4790k and if I remember correctly, it took about 20 to 30 minutes. I’ve also got an SSD drive, which I don’t think really matters. Also, I did for 4.11.1 and then when 4.11.2 came out the build time was much shorter… so, you will only have to endure a long build on your first pass.

teak

Thanks for the reply.
That looks like a really nice CPU :slight_smile:

Unfortunately I get a lot of C1001 errors from the release branch (found ~3 syntax errors, so there may have been some badly/malformed C++ that caused the C1001s).
I got a BSoD (MEMORY_MANAGEMENT) when compiling the 4.11 branch, So I have just used the prebuilt binaries.

This may be due to the extra RAM I installed, I plan on removing some and trying again sometime.
A VM also got some C1001’s from release.

This is the biggest piece of software I have tried to compile, I guess some problems are to be expected.

How much RAM do you have? This is indeed odd. Try deleting the intermediate folder…generate the files again and do a build from scratch (or a rebuild if you have been successful). Binaries are pretty stable and easy, that’s for sure! Good luck!

teak

I would suggest that you check your RAM and your hard disk. If you get these errors from the release branches, then something’s wrong on your machine.
Most common is file system corruption/bad blocks, or perhaps bad RAM. It’s also possible you have a corrupted install of Visual Studio/system headers.

I have one 8GiB stick and two 4GiB sticks of DDR3 1333 CL9.
The 8GiB has slightly different timings then the two 4GiB’s.
I will try removing one of the 4GiB’s sometime and test that.

I’ve tried that, But I am convinced that the problem is something on my side.

I’ve done some (quick) RAM tests that say all is fine, Same for the HDD.
The HDD is new (~4 Months old), So I don’t think that is a problem.

I have also gotten C1001’s inside a VM that has only been used to test cloning software.
So I think it is RAM (related) if anything.

I will be trying the 4.11 branch inside the VM soon.

Sounds like you have covered everything… I think you are right, might be RAM. Good luck!

teak

Another option is that some configuration for Visual Studio is wrong. It may include the wrong version of the Windows SDK, or define the wrong compile options somehow.

Can you copy/paste the first few C1001 errors, and the printed output command line that goes before that, if you turn on verbose build logs?