4.11.1 Random crash in packaged build

Hi there,

we have a serious issue. After packaging our game for Win64, we got a crash after loading a level. This crash occurs randomly. Sometimes it occurs the first time opening the level, sometimes after the second or even third time.

This crash has only been observed in packaged build.

The crash report (after checking “Include debug informations”) said the following:

Hope you can help. The build used was the 4.11.1 version from the launcher (no custom build).
The only third-party plugin we are using is FMODStudio.

Also interesting: The loaded level is not the first one, but the last one which is loaded (almost at the end of the game). All other levels work quite well. The level does not use anything special (code or blueprints) which the other levels don’t, as it only contains geometry, post processing volumes etc. but no real gameplay yet.

System specs:

Windows 10 64 Bit
Rendersystem: D3D11 (SM5)
Intel Core i5 3570K
16 GB DDR3 RAM (4x4 GB)
NVIDIA GeForce GTX 960
Driver: Version 364.72 (Release date: 3/28/2016)

Hope this helps. If you need more informations, do not hesitate to contact me. I have also submitted the crash report from the screen shot, including the link to this “question”.

Thanks in advance,

We’re also seeing crashing in 4.11.1 packaged builds that we weren’t getting in 4.10 packaged builds.

Here’s the dump file:

Dump Summary

Dump File: UE4Minidump.dmp : C:\Users\penrose24\AppData\Local\Microsoft\Windows\WER\ReportQueue\AppCrash_UE4-Rope_Main_41_d6abf13bbf4268c02d89feeb382fe0401153fb15_cab_2700380b\UE4Minidump.dmp
Last Write Time: 4/8/2016 12:36:03 PM
Process Name: Rope_Main_4100_v2-Win64-Shipping.exe : C:\UE4pkg\p20160408_RopeMain_UE4111_Vive_sh\WindowsNoEditor\Rope_Main_4100_v2\Binaries\Win64\Rope_Main_4100_v2-Win64-Shipping.exe
Process Architecture: x64
Exception Code: 0xC0000005
Exception Information: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.
Heap Information: Not Present

System Information

OS Version: 6.1.7601
CLR Version(s):

Was the information provided by me helpful? Any news on this (as in: Are you investigating the issue?)

Or do you need more informations? If so, what can I do?

having this crash in 4.12.5.
any time i try to start the packaged game this occurs. game works fine in editor and when running in debug through VS.

Hi everyone,

  • Does this occur in a clean, blank project with no additional content or is it limited to specific projects?
  • What steps can I take to reproduce this on my end?
  • Can you post your crash logs here so I can take a look? They can be found at \Unreal Projects\PROJECTNAME\saved\logs.

i just solved the issue in my particular case. the short story: in my postInitialize function (C++), i forgot to do an ‘if exists’ check on the object i was loading from path…which in this case was an anim blueprint.

However, there’s a long story: blueprint class inheritance. For unknown reasons, blueprint child classes are not inheriting their parent’s variables in some cases. in this case it was an AnimBP. so while a parent class had an AniimBP class assigned, the child class would load with ‘none’. I used post initalize to force the anim instance to be set to the correct blueprint which worked in the editor. however, in a packaged game, this path could not be found, so instead, I used begin play in the child blueprint to set the animclass to the correct BP.

Hi Kyoril,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.