4.11.1 Build errors (related to Windows 8 Kit and data types)

The issue is related to building a project with 4.11.1 version. It worked with 4.9 and 4.11 but its not working after updating to 4.11.1. The error is related to compiling the project using h files from Windows 8 kit

UnrealBuildTool: Cube.generated.cpp
MainFrameActions: Packaging (Windows (32-bit)): UnrealBuildTool: C:\Program Files (x86)\Windows Kits\8.1\include\shared\ws2def.h(249): error C2872: ‘INT’: ambiguous symbol
MainFrameActions: Packaging (Windows (32-bit)): UnrealBuildTool: C:\Program Files (x86)\Windows Kits\8.1\include\shared\minwindef.h(176): note: could be ‘int INT’

There are more but in the same category. My take is Unreal thinks I’m using Windows 8 but I’m using Windows 7 and I always had.

Not sure where to start to try and find a workaround. One thing I want to mention is that the Editor Debug Symbols I installed separately after I Installed the Core of the engine. Not sure if this matter. There was no such error in the past and the build process worked fine.



Could you please upload your error output lots as a .txt file? Please make sure you attach it to your next reply. I’d also like to know whether or not you’re having this problem with 4.11.2?


Sure, I’ll be doing this right away.

[link text][1]
This is the log file, does the same with 4.11.2 sadly.


[edit] I want to mention that the compilation works fine from within the editor or outside from Visual studio.

88124-ue4_11_2_project_build.txt (137 KB)

Reinstalled clean Unreal Engine 4.11.2 and the problem persists. I have no other Unreal version installed also.
I would also like to mention I haven’t included any windows specific h files or anything, there was no significant change in code from when it worked until it didn’t.

Sadly, I cannot install 4.11 back, it only shows me the latest version with the latest hotfix to install, so I guess I will have to find a fix for it.

Similar problem had happened here Windows Kits errors preventing build - Programming & Scripting - Unreal Engine Forums but with an older version.

One other thing I want to mention is that this happens on two different computers for the same project and it happened at the same time without installing anything new on those computers besides 4.11.1 (as far as we can tell).

Hey Eudrea,

If you uninstall 4.11.1 from your computer and you’re using our binary version from the Epic Games Launcher, you’re not going to be able to downgrade from 4.11.2 back to 4.11.1 or 4.11.0.

Try going in the Epic Games Launcher and click on Library > drop-down arrow by your version number > Options > and then make sure that the checkmark is beside Editor symbols for debugging.


I’m using the binary version. I had updated from 4.9.2 to 4.11 and then to 4.11.1 and then 4.11.2. I never uninstalled it until today when I wanted to check whether or not that was an installation issue.

The version I have installed is 4.11.2 yet when I went to Options I had all unchecked but the core files. I don’t really understand why that was because I specifically installed them all (including the editor debug symbols) today.

I can correctly debug the game in Unreal Editor so the symbols are clearly installed, otherwise I would get no call stack in crashes. I will be checking the editor debug symbols and to an update but that’s really strange.

Would you mind explaining why would that happen or how is the installer working?

Thanks for looking at it!

Alright, went to Options and re-updated everything in there, verified and its all good. However, the build process stops with the same errors.

Not to rush things or anything but do you have any idea what this could be? (since it seems to be happening to other people, perhaps this is something someone looked at in the past?) I’ve years of dev experience and any idea of where to begin looking is a good start.

On top of all, we are eagerly close to applying to Unreal Dev Grants and without a proper build we can’t do it. Our planned time frame is within 2-4 weeks for this.

Here there is a pre-alpha gameplay video from our game Positron we are planning to apply to Unreal Dev Grants. The video is private and not final but the project is real and in dire need of a way to make a proper release.

Let us know if you come up with an idea of what might be.

Your game looks great so far, keep up the good work!

Go ahead and upload your newest output logs, I’d like to compare them to your older ones. Also, are you building your project with blueprints, c++ or a mixture of both?

Please look at the following links, maybe one of them are the issue you’re running in to. If one of them happens to be the solution, could you let us know?

[AnswerHub: Error C2872][1] | [AnswerHub: Error C2872 (2)][2]


Trouble using windows includes with DWORD, INT - C++ - Epic Developer Community Forums
[2]: How can I use DWORD, INT.... in windows platform? - Programming & Scripting - Epic Developer Community Forums

[link text][1]

I already read those 2 answers, none of them are similar to our problem.
We are using ~95% C++ and only here and there blueprints. We haven’t included any custom library or windows files.

The thing I mentioned before and I want to emphasize now is that the game compiles fine in editor or in Visual Studio. The only place it doesn’t build is when I’m running the build process. Must be something related to how things are set up on build (I mentioned I cleanly installed Unreal the other day to make sure there is no strange thing happening with the other versions we had until now).

The errors start to appear in Module.Cube.cpp which is generated by Unreal, there must be something related to the way it is generated and what it includes and our setups or something related to that.

We tried every possible combination of packaging settings and Win32/64 but no luck.

88494-ue4_11_2_build2.txt (144 KB)


Could you try building your project for Win64 instead of Win32? Once you’ve done that, whether it fails or not, could you then upload those logs for me as a .txt file?

Also have you gotten this error to occur on any other project before, or just this project?

We’re investigating this issue, thanks for your patience and assistance. :slight_smile:

Thanks for looking into it.
Attached there is the log for the 64 bit version, it’s the same error.
[link text][1]

88794-ue4_11_2_builderror_64bit.txt (149 KB)

I never got the error with any other version or project. But I never ran any other project with this engine version, will do that and see if that happens with them as well.

Another project with similar complexity and features works fine, so there’s something to do with this one especially. This project was converted right now from 4.9.2 to 4.11.2 so it didn’t get through the process the other one did (update to 4.11 then 4.11.1).
Also, there cannot be anything from Visual Studio since the other one builds fine. Will try to clear any intermediate files the project generated and try a clean build.
It gives the same error after clearing the Intermediate and Saved directory.


Thank you for sticking with me on this. I rolled back so many versions that eventually I found the issue, there was some code (I haven’t even using but put as a class in the project to adjust later) which included “Http.h” file which is part of the Windows kit.
Sorry for the trouble, everything is fixed now on this part.
Thank you again!

You’re very welcome. I’m glad that you figured out the issue. Please let us know if you have any further troubles.

Enjoy your weekend! :slight_smile: