4.10 Vram consuption


I just updated my paper2d game to 4.10.
The first time i pressed play to preview my game i was greeted with a red warning that i had exceeded my texture pool by 3650mb! First time i ever saw this kind of message since i first started using Unreal (4.3).

After some digging around i read that Unreal uses as default a 1gb texture pool. That meant that my game was using >4.5gb of Vram! (i have a 4gb Gtx980)

I downloaded Msi Afterburner software to monitor vram consumption and i didn’t like what i saw. The second i opened unreal it went from 350mb to 3.9gb.
I created an empty map with one sprite and my player standing on top of it. Pressing play gave me the red warning saying that i was using more than 3.2gb of texture memory for ONE sprite on screen(the total sums up to 4.2GB). What the heck is going on?

Needless to say that when i compile my game or run it as standalone game it crashes after a few seconds because it runs out of memory.

I just submitted the automatically generated crash report. Please look it up so you can pinpoint the source of evil.

Heeeelp!! I cant work anymore.

Hello ,

If you would link me a copy of that crash report I can take a look through the logs to determine why there is so much memory being used.

I have a couple of follow up questions just to be sure I have all the bases covered.

1.) You mentioned your GTX 980. How much room do you have on the drive you are saving this project to?
2.) Are you using windows 10?
3.) Have you tried increasing your pool size via console commands? r.Streaming.Poolsize then set this to something like 5k. so r.Streaming.Poolsize 5000.
4.) Is the same amount of Vram being utilized in 4.9?

After I have this information I should be able to narrow down what is causing this.

and what a glorious beard! :slight_smile:

1)I have about 50gb free on my ssd.


3)Yes i have. I had set it in the default engine .ini. I added a value of 4000 and i still had a warning of 650 more. I haven’t tried 5000 nor have i done it through a console command but i guess adding it in the .ini is the same thing ,right?

4)No. I just reverted to 4.9 so i could work. By removing the .ini entry i get no such error and no crashes, meaning that the texture pool is under 1000 since that is the default.

I also get the error"PATHS NOT DEFINED or NO PLAYERSTART with positive rating" which is super weird because everything is set properly and i had/have zero problems with the exact same project in 4.9.
link text

I am not sure that this is the right report. In case it isnt just let me know to try and find the right one.

I have been doing some investigation into this and I have not come up with any reported issues regarding the calculation of pool sizes. Could you provide a test project for where this is occurring. Preferably one before 4.9 so that I can then bring a copy into that version of UE4. I will try to determine if information regarding the calculation between 4.8 and 4.9 is either changing or becoming corrupt.



I don’t think I will be able to provide you with a test project because 9 out 10 bugs that I report have to do with large projects that have seen many different engine versions. and thus I cannot replicate with a template.

I don’t understand the connection between Unreal calculating wrongly the texture pool size and Unreal actually using up 4GB of Vram or 32GB of Ram with a single sprite on screen, resulting in crashes or my whole desktop flickering like a broken light bulb.


As I was unable to reproduce this on my end I will need a test to even begin to investigate this issue. It’s one of these situations that it could be one of a hundred things. Would you be willing to provide a test, possibly with the one sprite on screen causing this issue to happen?

I think that you misunderstood me.

Of course I am willing. Thing is that I have already tried to reproduce this with a sample project and I failed. It is one of those things that appear only in large projects.

The only other solution is for me to send you my half finished game which is out of the question.

I will continue to try to reproduce this and if I succeed I will let you know.

Thank you.

There is something else that happens exclusively in 4.10 that might help us narrow this down.I believe these two are linked. When i package the game in 4.9 (and all previous versions all the way back to 4.3) the packaged game runs just fine(package method :development, windows 64bit).No errors whatsoever. In 4.10 it it is another story though.

After a few seconds of a white screen it crashes! Problem is that it gives me this error :‘You do not have any debugging symbols required to display the callstack for this crash.’

If you could show me a way to fix this maybe we could understand what is causing the crash and i have a feeling that this is linked to the streaming pool issue because 4.11 preview 1 is giving me the exact same problems as above.

Thank you.

So, if you go to your project and you enter the console command “debug crash” are you able to see a crash report window at all?

If I understood correctly you want me to fire up my project in 4.10 and run " “debug crash”. Yes in this case it pops up the crash window with this error:

"Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\Engine\Private\UnrealEngine.cpp] [Line: 4633]
Crashing the gamethread at your request

I am in such despair to make it work that i tried a little experiment. I created a new 4.10.1 paper2d sidescroller project from the template. I then migrated everything from my 4.9.2 project into that project.

After some tweeking by setting inputs, gamemodes,compiling plugins etc. it worked. But i still got the insane amounts of texture usage. After a minute or so into a play in session i got this:

Inside the log this seems rather interesting:

LogD3D11RHI:Error: Direct3DDevice->CreateTexture2D(TextureDesc,SubResourceData,OutTexture2D) failed
at D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Texture.cpp:432
with error E_OUTOFMEMORY,
Size=384x384x1 Format=DXGI_FORMAT_B8G8R8A8_TYPELESS(0x0000005A), NumMips=1, Flags=D3D11_BIND_SHADER_RESOURCE

Does this help anyhow? I am attaching the log as well for you to better investigate.[link text][2]

Hey ,

The last option is to attempt to recreate this on my machine. It says you are running out of memory but I am unsure as to why. The screenshot you provided is windows asking you to close Unreal. Now, you say this is only happening in 4.10. It could be that when you migrated your project from 4.9.2 that an issue arose during that migration.

I can try and test this issue on my machine and try to determine if this is a memory issue with 4.10. My only other suggestioin is to stay in a version of UE4 that is working for you.

I managed to get a crash log.link text

I have looked through your logs and have located the error of running out of memory. However, as a note, I also saw the thousands of warnings that you have. With that many warnings it is almost certain that this is where your memory is being allocated. Addressing these warnings may free up enough memory for you to launch your project.

You may also compare this log to previous ones to look for any previous errors/warnings. This way you can compare the project that works to the project that doesn’t.

I believe this is where the issue lies. After handling these warning and comparing your logs let me know if that handles memory problem.

Would you mind telling me where these errors are and how can i view them? The.log has no errors and if i open the .dmp inside VS i cant see a thing. Is there something “special” i should do in order to access those thousands of warnings?


I saw none in your latest log. However, Spartan.log from under your previous screenshot you will see many instances that say " Asset has been saved to an empty engine version. The asset will be loaded but may be incompatible. "


Yes that.
In order to figure this thing out i created an empty c++ project and migrated all my assets there. I was hoping that this would cure whatever was corrupted. Unfortunately it does the exact same thing as the “normal” updated version with the exception that it gives us a gazillion “empty version” errors.

Thats why i decided to send the one that only has the memory leak. Since i have zero errors and a memory leak with a crash log, is there a possibility for you to mark it as a bug to be fixed? It is super serious and i cant work.


Ok, thank you for the clarification on that. I am trying to determine from your logs what is causing your machine to run out of memory. In the meantime please stick with a version where you are able to develop.

I am, but problem is that because of some major changes to the plugin that i am using (responsible for all my animations) i am forced to move on to 4.10 +.

Plus the fact that paper2d development has stopped makes me super worry that there will be another 10 things wrong with 4.10+ besides this that i cannot see right now because of the crashes. I wont let this slip by without a fight! Imagine what is going to happen with 4.11. I might as well stop creating my game for game consoles. …

Thank you for trying to help.