4.10 Preview - Enabling Perforce crashes Editior

For Launcher Version of the 4.10 Preview:

[2015.10.16-14.29.48:209][748]LogWindows:Error: === Critical error: ===
Assertion failed: Module_libeay32

[File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Plugins\Developer\PerforceSourceControl\Source\PerforceSourceControl\Private\PerforceSourceControlProvider.cpp] [Line: 540]

Failed to load DLL …/…/…/Engine/Binaries/ThirdParty/OpenSSL/Win64/VS2013/libeay32.dll

There is a VS2012 folder with the dll inside but no VS2013 folder.

This of course happens in every project, both old copies that I want to convert to 4.10 and in a clean BP-Project created from scratch as soon as I go to Source Control and Choose the “Perforce”-Drop Down option.

Hey -

Thank you for the report, I was able to reproduce the crash and have entered a bug report (UE-22260) for further investigation.


This is for a later version (4.13.1), I’ll get a question posted as soon as I can figure out how to get the crash reporter enabled. Thanks

I am getting pretty much the same issue, this is one of two questions regarding this issue I have seen, both say “resolved”, but there is no resolution here… Where is this resolved? How can I find the info for the solution?

This was for 4.10? What version are you using? You can search for the issue number, for example UE-84793 is this url: Unreal Engine Issues and Bug Tracker (UE-84793) Sometimes they are not public though. (Above just as an example). Anyway, I would urge you to create a new Bug report here on answerhub. Post the exact crash log etc. and details and what you are trying to do.

Do you use Launcher Version or Source from GitHub? You dont need the crash report, just log files?

This is from Github source from what I understand. It’s including support. But I just tried 4.13.2 from the launcher and have the same result. If I select Source Control then “Perforce”, it crashes to desktop. Logs only show that things are closing down, but now why. I’ll get a bug in.

I created a new ticket here: 4.13.1 - Selecting Perforce when enabling source control closes editor - Pipeline & Plugins - Unreal Engine Forums