4.10 HTML5 projects won't launch

When I try to launch any html5 project with the new 4.10 version the process gets stuck on “Validating Executable for HTML5” . This does not happen with 4.9. I have encountered the same issue on another PC as well.

Hi PwnPwn,

I’ve tested 4.10’s HTML5 launch to Chromium and Firefox Nightly 64-bit browsers without issue.

I have a simple blank project that I put a couple of assets in the level with. I’m able to load the scene after it launches and move around without issue.

Can you provide more context to your question?

  • Have you tried testing in a simple blank or template project?
  • What browser are you using to launch to?
  • What OS are you developing on?
  • If the simple test project you make in 4.9 works but doesnt work on 4.10, please include your setup and what you did?
  • Also, make sure that you’re on the latest Python 2.7.10 and Emscripten builds and that these are correctly associated in the Project Settings > HTML5 SDK.

Thank you!



Yes I have tried a blank project. I’m running windows 10. I reinstalled emscripten and python, and also set these paths:
Mac=“/path/to/emscripten/sdk” ← (Do I need this one?)
Emscripten=“C:/Program Files/Emscripten/emscripten/1.34.1”

I added firefox nightly manually under the platform settings “HTML5 SDK”. I also installed chromium and added it there as well. Still no luck launching on either of them, it just keeps saying “validating executable for html5”

I reinstalled 4.10 all together. HTML projects still run fine on 4.9 thou.

These warnings keeps apearing in the log:

CookResults:Warning: Warning Unable to find package for cooking /Temp/Untitled_1
LogCook:Warning: Unable to find package for cooking /Temp/Untitled_1
LogStats:Warning: MetaData mismatch. Did you assign a stat to two groups? New //STATGROUP_Threads//FLauncherTask///Thread_227c_0///####STATCAT_Advanced#### old //STATGROUP_Threads//FLauncherTask///Thread_2bdc_0///####STATCAT_Advanced####
LogStats:Warning: MetaData mismatch. Did you assign a stat to two groups? New //STATGROUP_Threads//LauncherWorker///Thread_16cc_0///####STATCAT_Advanced#### old //STATGROUP_Threads//LauncherWorker///Thread_cb8_0///####STATCAT_Advanced####

Thx for looking into it!

I just realised this is not tied to html5, but any device I try to launch the project on. The process gets stuck on “validating executable”

Can you try to package/launch the game again and then in your Project Folder > Saved > Logs and post the text file here for the most recent log that includes this package information.

There is likely something here in the log that can help determine why it’s failing to complete the validating process.

link text

I made a fresh install of win 10 on another SSD and all the issues are gone. I still have the old install though, and I tried launching again to generate a new log file. Same issue, the log file is attached.

Being that it works on my new install I don’t really need any more help, but I figured the log might be of interest anyways. I can’t recall doing anything special with the old system that might have caused it to break, I just installed 4.10.


I’m glad you’ve got something that is working for you.

Looking at your log, it appears there is a bunch of missing assets that are getting flagged. This may be the likely cause.