4.10 cannot package the project

I just update unreal to 4.10 and I cannot package the project anymore (shipment/debugGame/development and Windows-64)

this is the error:

MainFrameActions: Packaging (Windows (64-bit)): CSC : error CS2012: No se puede abrir 'C:\UnrealEngine\Engine\Source\Programs\AutomationToolLauncher\obj\Development\AutomationToolLauncher.exe' para escribir: 'The process cannot access the file 'C:\UnrealEngine\Engine\Source\Programs\AutomationToolLaunch
MainFrameActions: Packaging (Windows (64-bit)): er\obj\Development\AutomationToolLauncher.exe' because it is being used by another process.' [C:\UnrealEngine\Engine\Source\Programs\AutomationToolLauncher\AutomationToolLauncher.csproj]
MainFrameActions: Packaging (Windows (64-bit)): RunUAT.bat ERROR: AutomationTool failed to compile.
MainFrameActions: Packaging (Windows (64-bit)): BUILD FAILED
PackagingResults:Error: Error Unknown Error

Thx :slight_smile:

Hey ,

In order to better assist you, could you please upload your build failure as a .txt?


Here is the full output log, but it isn’t giving more information, the error appears so fast when packaging.


[link text][1]

66964-outputlog.txt (6.51 KB)

youre now the fourth person ive seen with the same error on here and the forums posting in the last 4 days. This is surely a widespread thing?

I can package the project by opening the editor direclty with the .uproject. This issue only happens when I try to package the game from the edittor opened from visual studio


I seems like you’re likely using the debug option in Visual Studio. When you start debugging, it will launch the editor based on the current code rather than running the project directly from the .uproject.

If you are able to package your project through the editor, or through Unreal Front End, then all should be working properly.

Are you using 2015 Community of Visual Studio? If not, I would suggest updating it as soon as you can. Community would be the free version. We’re phasing out 2013 Visual Studio soon.

Please let me know if I misunderstood anything that you said in this post.


I allways have the “Development Editor” and “Win64” options in Visual Studio. And yes, with the update to 4.10, I updated my visual studio to 2015 too.

Now I’m facing a different problem: Unresolved external symbol on packaging - Platform & Builds - Unreal Engine Forums (I spend last week only trying to package my project :’( )

By the way, that error is still happening if I package from editor (launched from Visual Studio)

I upload here another file with the log of the package:

Thx :slight_smile:

[link text][1]

67774-unrealbuildtool-2015.11.23-13.50.37.txt (11.7 KB)

Hey -

Are you able to reproduce the build failure in a new project? I tried to create a third person template project and run it through Visual Studio debugger. Packaging the project was successful for me in Development and Shipping configuration for Windows (64-bit). Is there anything else that needs to be done to reproduce this on our end?


Finally, after cleaning my project, I can compile again from uproject, but the main question of this thread is still happening.

And yes, is the same with new projects, this is what I do exactly:

  1. Open the .sln of the project
  2. right click on the solution → Debug → Start new instance (the configuration of the solution is Development Editor and Win64)
  3. when the editor is open, go to File->Package project->Windows-> 64bits

Anyway, I think this is caused by something with the update of Visual Studio 2015 (got VS 2015 community with ReSharper).

Thx for all your help :slight_smile:


I have followed your steps provided and was unable to replicate the issue you originally had. My project built successfully.

Could you please let us know whether or not you can reproduce this in a new project? If not, could you provide us with your project to try and test this issue out on?

Thank you!

Hi ,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

@ , i am trying to understand the what is happening when cooking process starts. thats why i was trying to use cooking option on debug mode . but it leads to me :

" ‘The process cannot access the file …\Engine\Source\Programs\AutomationTool\AutomationUtils\obj\Development\AutomationUtils.Automation.dll’ because it is being used by another process."

What would be the proper process to step through steps that happens when cooking starts?


This error is caused by packaging in Debug mode through Visual Studio. Build the project in Visual Studio, and then open the .uproject file and package it from the editor. If you run in Debug mode, it’ll not be able to package the game.


For me, the solution to this was to edit the launcher settings, and go to Build > Advanced Settings, and untick “Build UAT”.

Hello, I had the same Issue.
I build a package on the desktop and got the error but when building in the project directory it worked. It seems like the error message is wrong. It is not used by another proccess. More like unreal engine hasn’t the rights.

Maybe you can change the and write options of your Buiuld Directory