Download

4.10.4 - Reimporting a mesh doesn't appear to update it?

Am I doing something wrong? Rightclicking an imported mesh and selecting “reimport” doesn’t do anything. I get the popup message as if everything worked fine, but the mesh doesn’t update. If I do an entirely new import and overwrite the existing mesh it works, but then I lose all my settings.

Are you sure you are overwritting the old fbx/obj ? Maybe double click your model in Unreal and somewhere in its properties, it should say where it import the model from. Can’t say more at the moment since Im at work and dont have access to it.

Thanks for the reply. :slight_smile: Yes, I am completely sure - I’m exporting the model again like every 5 minutes right now as I’m just blocking stuff out. It is definitely the same path and name - Unreal even gives the popup window about “import successful” when I hit reimport, the model just doesn’t update.

Hmm, I had that issue in the old UDK, but I haven’t had it in UE4. You could try and make a simple box and export and overwrite the old model, and see if it changes anything, if so, then try export again the original model and overwrite the box. This way at least Unreal can’t think its the same data and not import it.

Darn, it was a good idea. Just tried exporting something entirely different under the same name, as you suggested. Result is still the same - UE tells me import was succcessful, but the mesh doesn’t update.

First, check if your FBX version exporter is the 2014 (for 3DSMax it is called 2014/2015).

This problem also occurs to me sometimes…
When i export from my 3D app (3DSMax) i don’t overwrite my FBX export but i delete it and re-export it (with the same name at the same location).
IN the UE4 editor, what also i can do is not to reimport my mesh (right click+reimport) but import it from the FBX files in my folder (like from scratch)…i just have to assign again the material a second time…

There are some bugs with the FBX format sometimes…

Cheers+

Same thing is happening to me, reimport doesn’t work properly. It gets very annoying having to re-assign materials and lightmap resolutions every time I have to freshly import the asset. It’s weird if I reimport a texture it works grand, just the FBX has problems.