4.10.0 preview 4 needs Substance Plugin but none available

I am trying to start the 4.10 preview 4 version and it states that I need to install the substance plugin, but there is not a version 4.10 available for this plugin. Is there a special way to use the 4.9 version of the plugin?

Hi -

Are you attempting to open a clean blank project and getting this message or attempting to open a copy of an existing project?

Thank You

Eric Ketchum

an existing copy, I am updating from 4.8 to test

Ok so I have tried cloning a new copy and this time by choosing not to try and add the plugin it is opening fine.

I worked around this issue with 4.9 and a custom build if you’re compiling from source before you build go to the 4.8 folder in the Unreal directory /Plugins/Marketplace and in that folder should be a one named Substance. Copy the Marketplace folder and paste it in the new versions Plugins folder then compile. It should also work for the binary as well you just need to do it when the launcher is closed and then in installed plugins you should see Substance. I figured this out when 4.9 came out and didn’t have the “official” 4.9.0 plugin out yet and it worked perfectly since my characters for the game my company is working on use it. If you have models or assets that use substance and they still render/look bland you might need to reimport the model/asset once you add the plugin to fix it though normally restarting the launcher if you have it open when you copy it in or just having it closed should work as well. Hope it helps.