4.1 patch causing screen to flicker during UI interaction.

I am getting weird flickering when clicking on certain parts of the UI in 4.1.

In this case I was clicking on New Project.

Hi reefG,

I do not believe this is related. Please make a new answerhub post so we can assist you further.

Hi Mike,

This started directly after the 4.1 launch? Would you mind posting your dxdiag so i can have a look at what might be occurring? Thank you!

Sure.link text

I seem to have the same issue.
The flickering seems to appear whenever I move the cursor over an unreal editor or launcher UI item that triggers a tooltip to be displayed.

Here’s my dxdiag, in case that heps link text

If you switch your engine version back to 4.0.2 (via the Launcher dropdown menu), can you confirm that the issue does not exist in the older version?

Thanks

I can confirm that this issue is not in 4.0.2

Hrm. for me this appears even in 4.0.2. :frowning: Even the launcher itself has this issue.
I have the feeling this might be due to my laptop have a dedicated card and an onboard card. I checked that I set the launcher and unreal engine itself to use the dedicated card, but maybe that’s not working for some reason.
I’m gonna check if a driver change will help.

I played around a bit more. In the launcher it only happens on the lower left, when I mouse over the links.
In the editor itself the flickering only appears when I open a right-click menu and flickers indefinitely, even when I don’t move the mouse.

I made sure the editor and launcher was set to use my dedicated card. Regrettably I cannot turn off the onboard card in the bios of my laptop, because my dedicated card apparently goes through the onboard one. (?)

Is there anything else I can try?

Hi RebelMoogle,

Please check here for more information about the multiple cards:

Thank you for the information!
I installed the QFE and also check the logfile. It seems like only my onboard card is found:
[2014.05.11-16.18.31:477][ 0]LogD3D11RHI: Found D3D11 adapter 0: Intel(R) HD Graphics 4000 (Feature Level 11_0)
[2014.05.11-16.18.31:477][ 0]LogD3D11RHI: Adapter has 4027MB of dedicated video memory, 0MB of dedicated system memory, and 7881MB of shared system memory, 1 output[s]
[2014.05.11-16.18.31:477][ 0]LogD3D11RHI: Chosen D3D11 Adapter Id = 0

I checked the dedicated GPU load through GPU-Z, and it seems like unreal launcher and unreal editor are both using the dedicated card. (the load percentage goes up 4-5% when the launcher is up and 70% when the editor is up.)

So it seems like the problem is not necessarily choosing the right card.
My Desktop PC doesn’t have this problem however, which also has a onboard and dedicated GPU. There I am able to turn off the onboard one through the BIOS, though.

BTW. I just realized that the flickering appears on holding down the right-mouse button or left mouse button and moving the cursor over the toolbar buttons in the Editor.
This does not happen when I move the mouse over the buttons without holding down the RMB or LMB. There are no extra menus are anything else that is displayed.

Hi RebelMoogle,

What type of graphics card is your alternative card and what drivers are on it currently? There has been several cards that seem to be having problems with the editor on their latest drivers and reverting to older drivers sometimes seems to solve the screen corruption.

My Laptop’s dedicated GPU is a Geforce GTX 680M. I currently have the nvidia driver version 337.50 installed.

I just installed the 335.23 drivers and the flickering has disappeared! Thank you for the tip! I had forgotten I installed the beta drivers. >.> <.<

I can confirm the same as RebelMoogle. It seems to be a problem with the new 337.50 Beta drivers.

Thank you guys for the help!

Hey everyone,

I’m happy to hear this works for you. I will mark this as answered for tracking. If you have any further issues with this, please feel free to comment so we can continue in assisting you. Have a great day!