Download

4.1 github release prereqs

4.1 has been committed to github, but when I try to compile, it fails on the assertion that Engine\Content\Localization\icudt51l.dat is missing. This is obviously something in the prerequisites, but the zips haven’t been released on github yet. Anyway we could get the canonical version of this file? I’m not sure if it’s safe to just grab one off the internet.

As Mike said they are still in the process of getting the dependency files uploaded.

I have seen the unreal 4.1 repository with a ton of stuff in there. Will there be a zip format like the previous versions, when they are done?
I have looked at the git tutorial, but I am unfamiliar with this forking stuff. :wink:
I am not a developer or anything like that, just a fan.
Will it be available to download through the Unreal launcher?

There is a “Download ZIP” button in the right hand side menu of Git. if you go to “https://github.com/EpicGames/UnrealEngine/tree/4.1” and look all the way to the right, the last button is the Download Zip one. But you’ll still have to wait for the dependencies to be done first.

Oh! Where did you get that?

In any case, the prereqs are uploaded now, so no troubles.

Yeah sorry about this guys, this was my fault as I was publishing the binaries and followed my own directions wrong, causing some prerequisites to be omitted.

Good news though. The Required*.zip files on the GitHub releases page have been updated already!

You can either re-download them an unzip over your existing folder, or you can manually compile the missing binaries yourself (ShaderCompileWorker is the most important, but you’ll also want Lightmass and UnrealSwarm too.) It’s probably easiest to download the prerequisites again.

–Mike

I just redownloaded everything, deleted previous files and I’m still getting:
Error 1 error : appError called: Assertion failed: FPaths::FileExists(DataDirectory / TEXT(“icudt51l.dat”)) [File:C:\Dev\UE4\Releases\4.1.0\Engine\Source\Runtime\Core\Private\Internationalization\Internationalization.cpp] [Line: 188] C:\Dev\UE4\Releases\4.1.0\Engine\Intermediate\ProjectFiles\LogWindows UE4

EDITED: yeah I can’t find icudt51l.dat anywhere in the content zips.

Sorry you’re having trouble. I verified that the file is in the Required_1of2.zip file currently on GitHub. No one else has reported this problem to my knowledge. Can you double-check that all files were extracted to the correct location?

–Mike

Thanks Mike. I doubled checked my downloads and for some reason the browser was using a cached version of the previous zip (I have never seem that). I tried with another browser, redownloaded and now I can see the .dat file.

I’m building from the master branch (first time trying it) and got some errors about “couldn’t include fbxsdk.h”, as the master branch uses FBX 2014.2.1 and the prerequisites zip only includes the 2013.3 version.

So I downloaded the latest SDK from here and copied it over to the appropriate folder, but then got several errors like this:

What could it be?

By the way, I’m also getting this compile error:

But I guess that’s due to unstable code, right?

Edit: commenting lines 53 to 59 from fbxarch.h seems to have solved all these issues… I hope that instruction isn’t important :smiley: still compiling though.

Edit 2: nah, still getting the error about dtQuerySpecialLinkFilter. No errors about FBX SDK though.

Is that possible to create some repository for required packages? Because i do not like to download 1.5 GB again and again every update :frowning:

A few more #includes missing for building the master branch:

I don’t know if Epic will be including prerequisites for the master branch in the zips, but if so, these are the missing ones :slight_smile:

Edit: Ah, as with fbx, the master branch is using p4api-2014.2; the prereq.zip includes only up to 2013. nvtt was also updated to nvTextureTools-2.0.8 (2.0.6 in prereqs.zip). I’ll look for those SDKs now.

So after that the only error remaining is the error about dtQuerySpecialLinkFilter. And also…


1>D:\UnrealEngine\Engine\Source\Developer\ShaderFormatOpenGL\Private\OpenGLShaderCompiler.cpp(1489): error C2065: 'FGlslLanguageSpec' : undeclared identifier
1>D:\UnrealEngine\Engine\Source\Developer\ShaderFormatOpenGL\Private\OpenGLShaderCompiler.cpp(1489): error C2146: syntax error : missing ';' before identifier 'GLslLanguageSpec'
1>D:\UnrealEngine\Engine\Source\Developer\ShaderFormatOpenGL\Private\OpenGLShaderCompiler.cpp(1489): error C3861: 'GLslLanguageSpec': identifier not found
1>D:\UnrealEngine\Engine\Source\Developer\ShaderFormatOpenGL\Private\OpenGLShaderCompiler.cpp(1496): error C2065: 'GLslLanguageSpec' : undeclared identifier
1>D:\UnrealEngine\Engine\Source\Developer\ShaderFormatOpenGL\Private\OpenGLShaderCompiler.cpp(1501): error C2660: 'HlslCrossCompile' : function does not take 10 arguments

Ah, ok, the other two dependencies (which cause the two compile errors I mentioned) are Recast Navigation and HLSL Cross Compiler.

However, I noticed Epic has modified some stuff on Recast, so replacing with the original version from memononen’s github is probably a bad idea…

Epic, could you post the updated ThirdParty stuff for the master branch? Maybe remove that folder from .gitignore, for the master branch (since you seem to change some files – Recast, at least). Thanks! :slight_smile:

The latest preview build was updated with fresh dependency binaries last night. Our goal is to update it pretty frequently, at least until we can devise a better distribution mechanism for these files.

–Mike

Having issues, I downloaded the 4.1 source code and deps .zip files. I compiled the engine which went fine with no errors. But when i try running the UE4Editor.exe the load window pops up with the release information (4.1) but then immediatly closes. Doesnt start up the launcher or samples launcher window, nothing. just does nothing, WTF? Any idea’s what’s going on.

Thanks Mike!

Only missing speex_resampler now :slight_smile:

Guess I’ll go back to 4.1 until there’s a way to update third party stuff on master branch.

So… has anyone managed to compile the master branch? I haven’t tried since the 25th, as the dependencies apparently weren’t updated yet.

No luck this morning.

The ‘Latest Preview’ master branch snapshot on GitHub absolutely does compile and run. We’re still working on our process for updating the dependency zip files on a super-frequent basis.

For the last snapshot that we uploaded (called “Preview Build” release on GitHub), the dependency files are built for a specific snapshot of the code. That code is “tagged” on GitHub with the “latest-preview” tag. This means after forking and syncing the code down, you can switch to that exact snapshot of the code by typing “git checkout latest-preview”. If you don’t checkout using the tag, you’ll instead be using the absolute latest version of the code which may no longer match the dependencies for the last snapshot we uploaded.

We’re having many discussions here about how we can improve this process overall, so please bare with us in these early days. We’ll make sure it is awesome!! In the meantime, we’re focusing on frequently updating the latest Preview Build snapshots so you guys can work as close to HEAD revision as possible.

–Mike