3Ds Max smoothing Group Problem

I am having an issue with smoothing groups.

As you can see in the picture, the Polys of the dome are clearly visible and not smoothed, on the right hand side of the dome however they are.
All Polygons have been assigned the same smoothing group (I checked 5 times) but only ~50% of the Mesh is actually being smoothed in UE4.
I have also tried recomputing normals and tangents in engine and tried so many different import settings that I can´t remember them all.
Any ideas or suggestions would be greatly appreciated.
Thank you.

This is a bug in 3ds max. Fix by duplicating all the polys while in poly edit mode (and just delete the original).

Thanks for your reply, I have since realized that no polys are being smoothed correctly in this model (other models are fine) but if I remove the smoothing groups in Max it looks even worse in UE4 so there does seem to be some smoothing.

Try converting to Editable Mesh then back to Editable Poly > Auto Smooth and then Export. Passing the mesh through editable mesh has helped me in some weird cases like this.