Download

3DS Max Skin Weighting Mirroring help please...

I have half my weighting done on my character. When I enter ‘Mirror Mode’, select the right thigh envelope, and click on “Paste blue to green”, the middle screenshot happens. When I select the left thigh envelope, the bottom screenshot shows that weighting. The model is completely symmetrical, and the animation is off on my CAT rig. What am I missing?

Thanks.

It’s been a while since i’ve used max but i remember the pain of the skin modifier :p.

It is recognising the opposite bones ok which makes it strange. Are you mirroring on frame 0?

You could also try resetting the xForm, the mesh data might just need cleaning.

I am mirroring at frame 0. How do you use xForm to reset but yet keep the skinning I’ve done? Would I add it to the stack and then drag it below the Skin modifier?

It’s also strange that my mesh was displaying fine, but as soon as I re-opened the scene again my model turns solid white.

You could try that yeah, try collapsing it underneath the skin modifier too. The more effective xForm I found was under the tools tab (i think the hammer tab from memory?), it worked alot better for me than the modifier. Not sure if this will keep the skin modifier though.

Nearly the same thing happened to me for a character. I finished skinning it, saved it, re-opened it and the mesh went completely black even though the texture was still applied to it.

If none of that works i think you might just have to start again :frowning: That’s what i had to do.

The XForm modifier does not reset XForm, it’s simply to use a modifier to modify the mesh and not mess with underlying transform properties. Basically it allows you to alter the mesh without having to then reset XForm. If it’s already altered, it won’t reset it, you have to reset it from the Utilities.

I doubt the mirroring is directly affected by not having reset xform. Though of course you should always do it, regardless. Resetting a mesh after skinning is possible. You can copy the skin mod from the stack, then remove it, reset the mesh collapse it to editable poly, or mesh, and then paste back the skin to the stack. Then on the skin properties go to the Advanced Parameters and un-check Always Deform, then re-check Always Deform. That should do the trick.

As for mirroring, you need to actually mirror the correct sub object. You have a choice of mirroring bone, which in fact mirrors the envelopes, and a choice of vertex, which mirror any vertex level edits. If you only used envelopes to set up your skin, and you mirror vertex, it won’t do anything, because you made no vertex level edits. And also the other way around, so you have to mirror the correct sub object to get the information across.

When I used 3Ds Max, the weightpainting used to crash Max when I opended the tool. I dont know if it can be a bug.

Well I definitely dont want to re-do my weighting. Im running 2015, so you think they would have resolved those issues.

I even set up an new animation to test the skinning on the left shoulder and here are my results. That one area shifts the majority of the right arms vertices. I selected one of the moving vertices on the right arm to see the weighting, and it’s set to 0, so it shouldn’t be affected…

I’m running 3DS Max 2015, so you would think that the bugs have been worked out of skinning. It could be me too, so here are my steps with a brand new scene. Please let me know if I’m doing something wrong.

Load my CAT rig.
Load my character mesh.
I reset my transform on my mesh (XForm) and “Collapse All” in the stack so Im left with and edible poly.
Apply my Skin modifier and select all the bones except for the eye and tongue bones.
Set my Bone Effect Limit to 4.
Under Display I click “Show No Envelopes” since I prefer to manually edit the vertices by using Abs. Effect and weight painting.
Click Edit Envelopes and select the left thigh bone. (1st screenshot)
Edit my weights using above method. (2nd screenshot)
Click Mirror Mode, and clicked Paste blue to green vertices button.
3rd screenshot happens. It seems that it re-sets it to the original weighting.

What am I missing?

To be honest, not sure what’s going on. I’ve never had problems with skinning / mirroring… etc. From your steps that you take, it sounds ok. The only thing I can think from your older shots, is your mirror threshold is extremely low at 0.01. Although the preview bones should show up red when the mirror is not detected as valid, I would try and make that bigger and test it out. The default is 0.5, so in your case it is really low.

I can think that with such a low setting, and you still don’t get the red preview bones, your model must be tiny. And that can be another problem. Since scale matters in 3D. When the numbers gets too low, problems can start to occur. It’s possible Max thinks it’s valid, but in fact, it’s not. I don’t know the thresholds on there. I guess just check the scale and if in fact it is really tiny, scale it up to a more normal scale and try again.

EDIT:-

So, I did a test with really small scale, where a 0.01 threshold is marked valid, and it works fine. So I really don’t know what’s up in your scene.

I can check it out for you if you don’t mind sending the file, but I understand of course if you don’t want to. But I can’t seem to replicate this problem.

Thanks for doing some test scenes. My scale should be accurate and setup to work with U4: 1 unit = 1 cm. I’ve tried a variety of tolerances with little avail.

I appreciate everyone thoughts and suggestions, but I broke down and decided to go with the bonespro plugin for Max. After trying their demo it’s more than three times as fast for skinning, without all the headaches that comes along with playing with re-sizing envelopes. I don’t even get how Max’s weighting envelopes get setup with the initial skinning. They’re way off, even though my bones are identical to my characters geometry.

Anyways thanks for the tips!

If you find that you are using rather small numbers than expected that’s usually a sign that the relative scale of the model compared to the local scale is off. Modifiers always use the local scale as the seed value and if at some point if you scale the model using the scale tool then relative and local scale no longer matches.

If you select the model with the scale tool selected and says anything other than 100% that woulkd be your problem. The Xform Rest usually fixes it.

The player model is all white because there is a bug in the skin modifiers option to just show painted faces that turns on and off the objects “Vertex Channel Display” and can leave it turned on when exiting the modifier.

Just select the objects properties and uncheck it.