Download

3DS Max fbx export and UE4 skeletal Mesh Import rotations are not always 360 degrees

Hi,

I’ve noticed that when I export certain models in 3ds max as FBX format and import them into unreal engine the rotation angles aren’t always in 360 degrees for a full rotation. In some cases a full rotation (for all bones) is 720 degrees, in other cases a full rotation (again for all bones) is 27 degrees.

  • In 3DS Max I have used the reset xForm and collapsed the xform on all of the editablePoly objects.
  • The pivot points and translations are always in the correct locations on the UE4 imported skeletal mesh.
  • If I import the object as a static mesh the rotation of the base body is always the correct 360 per rotation.
  • I have setup the object hierarchy using object attachments (not a skin) and in some cases use dummy helpers in the hierarchy as well.
  • The rotations work as expected in 3ds max.
  • If I import the fbx object into Maya, and they export it as an fbx then perform the UE4 import the model loads with proper 360 rotations for all joints.

I don’t know if this is relevant or not, but I’ll add this because it may be part of the problem:

I have noticed that all of my pivots (although aligned correctly in Max) are always relative to the World environment.
For example, in a few of my meshes are airplanes with slanted wings and corresponding flaps. The flaps don’t rotate along the edge of the wing as they do in Max, instead the rotate along the pure Y axis (which is not aligned with the wing)

This means that there is some step in 3DS Max that I am missing, but for the life of me I can’t figure out what it is.

Has anyone else seen this situation and more importantly found out a way to fix the asset?

I’m going to Bump this thread as I still encounter this on a regular basis and I have no idea what is causing it and some even fail to import with proper rotations while using the Maya FBX exporter.

I am going to attach the Max source file and the FBX source file that exhibit the bad rotations.

In this particular case when you rotate the model by 90 degrees (visibly), the UE4 engine says it is only rotated by about 9 degrees!

Can you add some screenshots to show what is happening

Yep i see what you mean :wink: … just bake all your animations and the problem will be solved.
If you don’t want to bake: be sure to export with the latest FBX exporter…Also, try a tiny thing: before exporting, choose ‘local pivot’ for the appropriated objects you want them to move along the local axis.
My two cents.

Here is an example of the problem (valid steps to reproduce):

Direct Zip Link:
https://answers.unrealengine.com/storage/attachments/70783-badrotations.zip

If you go to this location:
https://answers.unrealengine.com/questions/347791/import-of-skeletal-mesh-have-arbitrary-bone-rotati.html

You will be able to download the zip file of the max file and fbx file that I am attempting to import that demonstrates the problem. I tried to remove as much detail as possible to keep the zip size small, but I couldn’t get it small enough to put the link directly in the forums.

I tried posting it here, however the size limit of zips is 97KB (yet a gif max size is 5MB… go figure)

Also, its not just 3ds max that does this. The FBX was exported using Maya and it does the same thing

I have added a link to the zip file (which is on the unreal answer hub, the .zip size limit is simply too small on the forums)




As you can see, I only rotated the turret about 9 degrees within the Engine, but the model itself has an applied multiplier that see seems to be about 10 times the rotation value.

I have NO IDEA where that multiplier is contained within the Asset File, let alone how to remove it.

I changed the my units to automatic instead of centimeters in 3DS Max export FBX settings and it fixed the problem.

Can anyone else confirm this?

That doesn’t sound like it should fix anything, but who knows?
Does the problem still happen if you bake all animations?