Download

[3ds Max] Creating simple bone help...

Hello everyone

I’m trying to create a burning fuse effect for my mesh. A guy recommended me to create a bone and animate it going down the fuse, and then in UE4 create a socket to that bone and attach a particle effect there. So here I am in 3ds max (with zero xp in animation xD) trying to add a bone…

So I have created a simple bone in 3ds max, and tried to apply the Skin modifier to add the bones to my mesh and removed the weights.

Here’s what I did

And after applying the skin modifier adding the bone…

Aaaaaand when I hit the collapse all in the stack modifier, nothing happens… Can someone help me or point me at quick tutorials? I’ve tried searching but all were really long and didn’t want to watch long tutorials for such simple thing.

You dont collapse a skin modifier.

so… I should animate while the skin modifier is active? but how do I export it then?

You want to make sure that ALL the vertices have zero weights. Go into the vertex weight dialogue (its got a dialogue that shows you weights for selected verts, so select them all, then open the dialogue and set them all to zero for that bone.

Now animate the bone position as you would any animation using bones. Don’t collapse the skin modifier, it needs to be there for the FBX to know you want to use bones. Now export to FBX and make sure animation is checked. Import the object and it should have the option for skeletal mesh, import the mesh and the skeleton, then inside max add the socket to the bone and voila!

I’m sure there are a billion tutorials on youtube about this by now.

Just to be clear, when we say “dont collapse the skin modifier” we mean don’t try and collapse the modifier stack back to editable poly/mesh. Basically your modifier stack should have the poly/mesh and the skin still on it. Then just export selected with the object selected and the FBX exporter will pick up you have a skin on the object and ask if you want to export animation, which you do :slight_smile:

Thank you zoombapup!

Well I wasn’t sure what to search for on tutorials. Thanks for the tips, I will try them out. Btw where is that “vertex weight dialogue” located? I couldn’t find it.

This is what I did.

Now I’m not really sure what to do, the bone still affects all vertices

Edit:
Found it, removed all the weights :slight_smile:

Okay, here’s a new problem. I’ve decided to make a video, to explain easier.

Create 2 bones.
One is situated at 0,0,0
Skin the mesh with full weights to it. Add your other bone. The one you animated.
Link the animated bone to the root bone which is at 0 0 0

Problem solved

Yeah, it might be that Max doesn’t allow you to only use one bone and won’t allow it to have zero weighting (i.e if there’s only one bone it’ll bind everything to that). So do what Crocopede suggested and create another bone, weight everything 100% to that one, just don’t move it. Animate the other bone (make sure it has zero weights on any vertices) and you should be good to go.

I understand now. But should the two bones be linked? I mean connected or they should be separate objects. I will try both and see how it works. Thanks.

Its good practice to have a hierarchy of sorts.
Make sure the root is zeroed out on rotation and location.

I feel like this could be achieved through materials, with no need for an animation like this. It’s not ideal for all situations, but in this case, you’d just animate the alpha channel on a masked material for the wick. UV it correctly and it would look almost exactly the same.

To pan the UV’s, you can manipulate a material parameter with a timeline in the BP or you could use material curves in persona.

Just an alternative.

-Matt W.

Thanks for the suggestion, but this seem even harder for me than creating an animation :smiley: I’d rather animate it.

Well I tried create a root bone zeroed at rotation and location. Then I created another bone called fuseBone, that I have animated it. Worked just fine. But when I linked it to the root bone, the animation was broken.

Links must be done before animation.

****… whatever I tried it just doesn’t work …

Did as you said:
Created 2 bones. One called RootBone zeroed for location and rotation and added weight to the whole mesh. The second FuseBone has zero weights for the mesh and is linked to the rootbone. But whenever I move the fusebone, the rootbone rotates too and breaks the animation.

Here:
ee7b986f1d2ba82e1b477de204ecd7395879ef35.png

And when I move it:
41e4ceb10d8d775fd03f3e5a01b6cd9cba5c5f2d.png

I don’t have Max open in front of me, so I might get the wording wrong, but open the Bone Tools, then look right at the bottom, the bone properties, or whatever, there’s a check box, I think it’s called Bone On, and it will be checked by default on any bone. So select the fuse bone and uncheck that box.

This will basically free the bone so it can be handled without influencing it’s parent.

Delete the bones. Remove the deleted bones from your skin modifier.
Create the 2 new bones. Individually. They must not be connected to each other.

Add the weights again in the skin modifier.
Now link the top bone( fuse bone) to the bottom bone… the root bone. Not the other way around. It is very important to link the top one to the bottom one.
That means your root bone will be the parent. Unless you add custom movement or rotation constraints the root bone will not be affected.

Now You can animate the fuse bone.
I think what happened was that you linked the root bone to the fuse bone. Which is why the root moved and rotated when you animated.

What you can do is freeze your transforms by alt-rclick on the bone and select freeze rotation, or transform. That way you can zero back.

It would be much more beneficial to you to go do a few basic rigging or other tutorials on the autodesk channel. This will teach you the basics you need… i know sometimes we all want quick results, but sometimes its quicker to learn a lot of stuff we dont need to understand the broader picture.

Thanks Crocopede, I’m watching a tutorial on Digital-Tutors about rigging in 3ds max. But I thought that this was a bit different and easier to do.

I will try your method and see how stuff works out. In case it doesn’t work, I will try to finish the rigging tutorial and try again :smiley:

Thanksk for the help everyone! :slight_smile: