Download

3Ds Max CAT Animation to UE4

Title kind of says it all. Now I know CAT isn’t necessarily the best way to go about animating something for Unreal but I have a lot of leftover CAT animations I made from school. So far I haven’t had any luck exporting them from 3Ds Max to Unreal.

FBX works just fine…just did some test imports. Check the import animations box on the import window that pops up.

That’s weird I can’t for the life of me get a CAT based animation in Unreal. Is there like a naming convention I’m not aware of?

Try running with -log at the end of your editor.exe to get a log running. Then re-import your object and see if that throws up any more errors. Also, and i am just grabbing at straws here, but are you doing any bone scaling by any chance? Not sure if UE4 supports it or not but UE3 definitely did not support bone scaling so maybe if you are doing that try and get rid of it.

Did you ever get your import to work? Are you exporting your mesh and anims using fbx? I’ve brought in several CAT anims as fbx so far, with no issues.

Are you able to get non-CAT animations/meshes into Unreal? Are you getting any type of error message?

Check a few things:
FBX plugin up to date
Make sure you have the correct import check boxes checked. (ie don’t have Import Rigid Mesh, if you have a skinned skeletal mesh)
are you exporting “all” from Max? Do you have any other data in your Max scene?

Nope still no luck. Checked FBX version, keep getting Bind to Pose errors and multiple root errors. Lemme try to make a CAT rig again from scratch and see what happens.

UPDATE: Ok so I at least got it to import but still getting errors like “bind_to_pose invalid” and scale on Roothub invalid. But at least the animation is playing correctly in persona.

Do you have a scale value of 1 for your joints?

just wondering if anyone is having any luck with getting CAT rigs into Unreal 4. If so please could you post anything special you needed to do? I’m not having any luck at all…

Show us screenshots of the import options, error messages etc. It’s hard to guess what you have done wrong.

thanks got it working in the end. I had a bone in the skin modifier that shouldn’t have been there (doh!)

I still get the invalid bind pose warning when I import though (guessing the same thing as paper hero above) but everything seems to be working fine despite the warning. Once I’ve figured everything out and am sure its all working correctly I’ll probably put a youtube tutorial up going through how to do it so hopefully that will help some. Personally I really like CAT, especially for non bipedal characters, so I’m glad to have got it working :slight_smile: