3ds Export Problem regarding UV Channels


First of all, I know this problem is caused by 3ds Max and not by UE4. But I am hoping some of you guys may know how to fix this problem. So, problem is, I am using 3ds Max 2016 ( ıdk which SP). When I export my project as .FBX, some of the objects dont export with their UV Channels. Some lose second channel only, some lose only second channel and their first channel would be blank. Now there are 850 (I’m using TsTool for mass export) seperate meshes in my project and about 120 of them lose their UV Channels as explained.

After doing some research, I found how other people fixed this problem but none of them worked for me.

  • Collapsing all modifiers → Export
  • Converting to editable poly → Export
  • Converting to editable mesh - >Export
  • Adding edit mesh modifier → Export
  • All above together → Export
  • Exporting without TsTool
  • Exporting with ASCII FBX 2014/2015
  • Exporting with Binary FBX 2014/2015
  • Exporting with Binary FBX 2016
  • Unchecking triangulate
  • Generating second channel within UE4 doesnt work because first channel is empty.
  • Deleting 3DS user profile

I made sure that every option was correct. Weird thing is other 730 fbx are imported properly with thier channels.

Now I know this is caused by 3DS Max 2016 because I imported those fbx to Max and they had 2 channels but second was duplicate of first. And when I import it in UE4, second channel was gone and first channel was empty. I saw some similiar post on Autodesk’s help section. Some people had this with Max 2015 SP3. But as I said their fix did not work for me.

Can you guys try to export this object with your 3ds, so we can see if the problem is with my 3ds version?

Is there anyway to import uv map after importing mesh?

max file, without collapsed modifiers: https://drive.google.com/open?id=0B-lb1P0opFRyZG5YVjZVVVZnOTA

fbx file: https://drive.google.com/open?id=0B-lb1P0opFRyTGV0UHBzMUdLeGs

uvw file: https://drive.google.com/open?id=0B-lb1P0opFRyVEc4Sk5ia0xscTg

Thank you.

there have been multiple reports about issues like these the past few months, and I think its been solved since 4.13 but I am not sure.

(so this is basically a bump till someone else can answer properly :stuck_out_tongue: )

I have tried it with 4.13. Its the same result.

I forgot to post it but I found the fix. Its caused because how 3ds max handle uv channels and general information of that specific object. I am not an expert on it, in their documentation they explain how it works. Basically what I did was

• Export (save) second uv channel ( Bc I spend so much time making them :slight_smile: )

• Collapse all modifiers

• Use steamroller to create uv channel 1

• Import ( load) the old uv channel back to channel 1

• Use steamroller to create uv channel 2

• Import the old uv channel back to channel 2

As you can see its a lot of hassle to go through 120 seperate meshes.

If anyone knows a better way, please post a comment :slight_smile:

Note: Fixes listed on question works for soem of the meshes. Problaly %20 of them. But fix explained on this comment works for all of them.