3D Widgets wont work anymore in 4.13

My project has been broken since 4.13. I was hoping it would be fixed once the Preview would be over but no such luck. The 3D widgets stopping reacting to the mouse (buttons don’t react to clicking or hovering). In my project you can use a laptop, the camera blends to a camera on the laptop actor and I use SetInputModeUIOnly with the 3d widget selected. It was working all fine in 4.12 but once I move to 4.13 the widget moved slightly (about 0.5 its height) and it stopped reacting to mouse completely. I saw there was the WidgetInteraction component but I am very confused how it’s supposed to work. The videos and documentation implied it was only meant for motion controllers. I set it to debug mode so that I can see where it’s pointing at and when I am using the laptop the arrow doesn’t seem to move at all (probably because it’s using the camera on the laptop actor). But even when the camera is not set to the UI is not reacting to it at all. I tried switching to SetInputModeGameAndUI and changing lock mouse settings but nothing seems to work. I tried creating other Widgets as well, but they didn’t react to mouse either.

I am not 100% sure if this is a bug or something just that is supposed to be done differently in 4.13.

I’m having the same problem.
Looks like the answer can be found here: https://answers.unrealengine.com/questions/480136/3d-umg-widget-stopped-working-in-413.html

3D Widgets now work differently.

Yes, I didn’t realize there was a “Mouse” option. I was going through the options before and saw it was set to “World” and assumed it was either “World” or “Local”. Also, in my case I needed to switch to SetInputModeGameAndUI to have the WidgetInteraction register the mouse clicks.