3d Widget washed out when game starts!

Hey everyone.

I’m working on a 3d widget for my VR game.

It looks fine (colors saturated as they should be) in the blueprint and in the editor, but as soon as the game starts, it’s horrendously washed out - no matter what I do! I tried adjusting the post process volume auto exposure, tweaking all sorts of parameters, and even making my own widget material from scratch, but it still does it. (see picture below)

Does anyone have a fix for this?

Hey Oraclefish!

While this could be any number of things, I’ll discuss a few options with you.

Since everything within the widget seems to be washed out, my gut feeling is that a parent widget’s “content color and opacity” has a value you might not be aware about. Be sure to double click the color and confirm it’s a #FFFFFFFF hexcolor.


Make sure you check the rgb values of every parent widget. Make sure to be thorough as you check each parent. For instance if the widget is being used as a user created widget in another user widget blueprint, then that will have a separate “Color and Opacity” value like this.

If these two options don’t do the trick, then conduct a test. Add a different widget entirely and see if that color is getting washed out. If it still does, then it’s probably another top level widget that’s affecting the colors. If not, then it’s a problem within the original widget.

If that’s not the case, then conduct another test. This time, add your widget to screen space instead and see if you still get the issue. If it still happens, then it still points to being a problem within the widget. If not, then it’s a problem with one of the components shared with your widget component.

I hope that this helped!