Download

3D Widget display issues

Hi All, apologies if this has been covered, but my searches haven’t helped so far…

I have set up a laptop on a desk, created a Widget and attached it to the laptop blueprint. In the Laptop viewport i am seeing things displayed as i want, but in gameplay it is just all black. I have put together a standard Hello World to illustrate the issue (below).

I’m sure i have just missed something obvious, but I’m currently scratching my head.

Please let me know if you need anymore information.

In the laptop blueprint, you have added a “widget component” and set the “widget class” of the “widget component” with your widget?

That’s Correct.

Image of the laptop blueprint screen…

https://forums.unrealengine.com/filedata/fetch?type=thumb&filedataid=187319

so i have tried a new project, created a blueprint actor with just a widget in it. I get the same result, just a one sided black rectangle. I am running UE4.24.3, is there some extra setting i am missing? tried it on the 4.25 preview as well… same result.

if i change the User Interface Space to Screen from world, it works as a billboard always facing the screen, not the effect i am after.

When you change it to screen space, is it showing Hello World? Or does it still show a black screen?

Also for the sake of testing, try changing the rotation of the widget to always face the player. You can do this in Event Tick using something like this:

If it ends up showing the correct information, then it might perhaps be a rotation issue.

changing to screen space:
screen-space.PNG.jpg

Called using Create Widget command:
called-as-standard-widget.PNG.jpg

Widget Rotation with above example (Switched back to world setting):
widget-rotation.PNG.jpg

Alright, since its being rendered in some form in the world space, it could be an issue with the widget facing the opposite direction. Unless the widget is two sided, that usually results in seeing a black screen. So remove the Event Tick logic from last post, and try changing the Yaw value of your widget component from -90 to 90.

just get a one sided black rectangle pointing in the other direction… :frowning:

So i had this project loaded in Automotive, Migrated all of my assets to a new Game type file and it works perfectly.

Is this a bug in the Automotive settings?

Haha well good to hear that it’s fixed. I was also kind of running out of things to try out at this point. Not sure about the Automotive though.

It did appear to be a level specific issue as creating a new level removed the problem. Can only assume it’s some kind of render / lighting setting somwhere.

thanks for the input, one of my colleagues stumbled across the answer, would have been scratching my head for a while

Final input on this…

Got an email response from Epic Games, this issue with the automotive project was due to the default sun/sky settings and the default emissive value for the widget material. Basically the sunsky is too bright and the widget material is not bright enough.

I added a multiplier to the material emissive value (about 2000) and it now displays.

3 Likes