3D UMG widget looks washed out

I created a 3D widget and placed it on the level. I disabled all the post processing in the editor. Yet the 3D widget’s color looks washed out compared to adding the same widget directly to viewport.

This is how it looks if i add it to viewport directly.

And this is how it looks if I add it as 3D widget into the world

Not just the color, 3D widget doesnt look as crispy as the viewport menu looks.

How to make the 3D widget looks exactly like how its look when I add it to viewport? Crispy and colors not washed out.

After i disabled postprocessing nothing happened, but when i detach from controller in editor its crispy and not washed out. But when I posses controller in editor post processing is happening again. I added PostProcessVolume and disabled everything and checked everything and there is no difference at all! I unchecked everything still no difference. Its same washed out look. Does postprocess volume effect 3D widget at all??

1 Like

Your 3D widget could be affected by the auto exposure settings in either your camera or any post process effects you have placed in the world:

“Eye adaptation is a feature in the engine that mimics the way your eyes adjust in real life depending on how bright or dark your surroundings are.”

This is the top search result in Google, but the answer I found to solve the issue is here

For anyone using UE5, it looks like they’ve added this nice “Apply Gamma Correction” button directly to the widget component which fixes the issue.


1 Like

Enabling the Apply Gamma Correction changes the colors but its still very different from the actual reference image. Below i have 2 images,

  1. Apply Gamma Correction ENABLED

  2. Apply Gamma Correction DISABLED

Are there any additional settings in the Textures or Post processing that can help me with this ?

1 Like

Would be interested as well.