Download

(39) Rama's Extra Blueprint Nodes for You as a Plugin, No C++ Required!

Hi Rama

I have tryed to install your plugin, but it doesn’t work.

I followed this instruction:

  1. download my editor / BP plugin and put in a directory directly off of your main project directory called “Plugins”

spelling must be exact

  1. Load UE4 editor and go to Windows->Plugins

  2. Find my plugin and make sure it is checked as being active

  3. maybe double check #3

  4. close the editor.

  5. go to YourProject/Config/DefaultEngine.ini

  6. add these lines:

[/Script/Engine.Engine]
UnrealEdEngine=/Script/VictoryEdEngine.VictoryEdEngine

  1. Load UE4 Editor again

  2. click on any static mesh actor

  3. You should now see the Victory Editor HotKeys button in the top left

  4. If you hover mouse over this title area any time, you can get the list of hotkeys

  5. Enjoooy!

But I don’t see Victory Editor HotKeys button in the top left and if I press the V key nothing appen.

This is my DefaultEngine.ini file

GameName=TestVictoryPlugin

[/Script/EngineSettings.GameMapsSettings]
GameDefaultMap=/Game/Maps/Example_Map
EditorStartupMap=/Game/Maps/Example_Map
GlobalDefaultGameMode=/Game/Blueprints/MyGame.MyGame_C

[/Script/Engine.Engine]
+ActiveGameNameRedirects=(OldGameName=“TP_ThirdPersonBP”,NewGameName="/Script/TestVictoryPlugin")
+ActiveGameNameRedirects=(OldGameName="/Script/TP_ThirdPersonBP",NewGameName="/Script/TestVictoryPlugin")
UnrealEdEngine=/Script/VictoryEdEngine.VictoryEdEngine

Thank you for your help. :slight_smile:

Hi there! Yea happy to help, but why did you feel you need the latest version all the time? The core structure hasn’t changed much over the different engine versions. Can you give me better sense of what you are keeping what you are removing? Will work on a general plugin template at some point :slight_smile:


**Stone Jonez Thou Art Selected**


[QUOTE=StoneJonez;162313]
For the record, I literally only changed two lines of code to get it working in 4.5. What's happening when you try to get yours working?
[/QUOTE]


Haha there's no issue other than I've never tried because I dont have preview versions of the engine. I am working about 5 different projects all of which are on 4.4 and I have 3 versions of the engine on my computer already :)

So! 

Guess what!

You are selected StoneJonez!

Should you wish to be, you can be the official preview version Victory BP Library person (OPVVBLP)!

Should you wish to bear the honorary title of OPVVBLP, you could be the one to maintain preview versions of the Victory BP plugin! You could add this to a subsection of my wiki page and also I will make a space for it in my main original post in this thread :)

:)

Rama

You will have to post your DefaultEngine.ini config file.

And do you see the Victory BP Library when you go to Windows->Plugins? Does it show up there at the very bottom of list?

Also, someone mentioned that non-github 4.4.3 has problems with plugins somehow

Are you on 4.4.3 and using only the non-github of 4.4.3 ?

I’d say wait till 4.5 and we will address the matter then ( a few days from now)

thanks rama
i have been using 4.2 until recently when i downloaded 4.5 preview. i use the ones from github so i can test html5 and have the source available, so why not get the latest.

the things i added to your plugin were specific to the tests i was doing at the time and probably no use to anyone else. it was just easier to add them in there as my plugin attempts failed.
ill have another go at a plugin at some point, if i see the error i was making ill be sure to let people know.

That’s quite an acronym! I have no problem with that! I actually have your newest update working in 4.5 too, but I’m not at the right computer at the moment. I’ll post it up tomorrow night (or morning, if I have enough time before work).

New Plugin For Community and You Tegleg!

I’ve posted a plugin template that you should find quite easy to adapt to your needs!

It is a fully functional plugin sample, containing some nodes that I found useful for doing AI coding in Blueprints.

But the main purpose is to give you a plugin template to use however you like!

Enjoy!

Rama’s AI Plugin Template



[QUOTE=StoneJonez;162780]
That's quite an acronym! I have no problem with that! I actually have your newest update working in 4.5 too, but I'm not at the right computer at the moment. I'll post it up tomorrow night (or morning, if I have enough time before work).
[/QUOTE]


Let me know when you have the link you'd like me to put on the wiki in your own section "Preview Versions"

and in my original post of this thread!

Rama

GameName=TestVictoryPlugin

[/Script/EngineSettings.GameMapsSettings]
GameDefaultMap=/Game/Maps/Example_Map
EditorStartupMap=/Game/Maps/Example_Map
GlobalDefaultGameMode=/Game/Blueprints/MyGame.MyGame_C

[/Script/Engine.Engine]
+ActiveGameNameRedirects=(OldGameName=“TP_ThirdPersonBP”,NewGameName="/Script/TestVictoryPlugin")
+ActiveGameNameRedirects=(OldGameName="/Script/TP_ThirdPersonBP",NewGameName="/Script/TestVictoryPlugin")
UnrealEdEngine=/Script/VictoryEdEngine.VictoryEdEngine

Yes I see Victory BP Library at the bottom of the list.

I use the 4.5.0 non-gthub version

Good news :slight_smile:

I tried to use “Rama’s AI Plugin Template” (I have put the folder in the plugin folder inside unreal 4.5 folder) and I receive this error: "Plugin VictoryAI failed to load because module “VictosyAI"mdoes not appear to be compatible with the current version of the engine”

thanks Rama, awesome :slight_smile:

You’re awesome Rama!

I love how you take requests and then add even more!

If you don’t mind I could post some updates here to show how your plugin is helping me with the project.
And thank you very much again!

Sure I’d love to see how my plugin has helped you in this thread!

Anyone else feel free to post pics/videos of your projects that have been facilitated by my plugin!

:heart:

Rama

Rama. Big trouble. Now my project is stuck in a rock & a hard place. It cannot be open after converting to 4.5. Said your dll files are build with a different engine version. WHen I said rebuild them, it fails, with a cannot be compiled error.

Have you updated your plug in in for 4.5 already?

4.5 Update Released

The latest version of my plugin is now on 4.5!

Enjoy!

Rama

PS: Starseeker let me know how it goes now!

Thanks Rama, you are the man, I will try out tonight!

Edit: Works!!! Thanks again.

Yaaay!

You’re welcome!

Rama

**New Node

Get Static Mesh Vertex Locations!**

Dear CatchPhyre,

As per your request I have now made a node to get the rotated,scaled,translated positions of all vertices of a static mesh!

This node is live in the current most recent plugin version!

Please refer carefully to my picture of how to set up this node correctly!


**Pictures**

![560b4f2b24fb116ffc5c2ddfd4f04754501ad6c2.jpeg|967x742](upload://chbi83K9r7yN6RpDf900WV9lpJM.jpeg)

![75e2b513ac387b6a626ff0e14fe5743f8f3e6a2b.jpeg|1280x960](upload://gORA6cRKTZxgajgGapD8D7bjC2v.jpeg)

Enjoy!

Rama

PS


[QUOTE=Skuba;160985]
Thx for the plugin Rama!
[/QUOTE]


You're welcome!

**[FONT=Comic Sans MS]Congrats on your first post, welcome to the forums!**

:)

Hello Rama, sorry to bother you again, I got this error when I try to launch my game (in the editor its fine).

VoctoryError.JPG

Only to ask if the Victory Library is not really for ‘launch’. or I may missed some setup/steps.

Rama you are incredible, just so you know! Thank you for your work! It’s really handy ^^

You will get that error until Epic makes plugins compatible with BP only projects :slight_smile:

Till then you can’t package your game properly, it’s something I’m told Epic should have done before the new year :slight_smile:

This affects all plugins, there’s nothing I can do about it :slight_smile:



[QUOTE=Dakraid;164722]
Rama you are incredible, just so you know! Thank you for your work! It's really handy ^^
[/QUOTE]



Hee hee! 

Great to hear from you Dakraid!


♥

Rama

Thanks Rama for the swift response. I am sure Epic will do something about plug-ins.

957573db818ed77a656f4e3fd23962cb4ebeb026.jpeg

New BP Nodes for Spawning Actors in Sublevels!

This node will spawn an actor from a class into a sublevel of your choosing!


**Download Link**

https://wiki.unrealengine.com/File:VictoryPlugin.zip

Ease of Use

You can simply enter the name of the sublevel!


**Bonus**

I've created a node that returns an array of the names of all levels that are currently loaded and visible!

In this way you can figure out what exact name to use with my SpawnActorInLevel node!



File Size Reduction

I reduced the file size of my plugin dramatically by removing the debug files. Plugin will still package great!

And now the plugin is < 500kb in size.

So the most recent upload is actually a valid file!

Enjoy!

:heart:

Rama