360 video player working only front half of the sphere in Gear VR

Hello! I’m trying to make a 360 video player for the Gear VR. I already have the stretched video, and in order to display it, I’m using a spherical mesh with flipped normals. I don’t even know if this is the correct way to do it, I found very little information about this on the web.

See attached Project to see my solution (I removed the video from the project because it is too heavy, but you can see it on YouTube, it’s one of the videos released for the Samsung Gear 360 launch: - YouTube )

My problem is that everything works fine in the editor, while it is not displayed correctly in the Gear VR: the front hemisphere works as expected, moving my head allows me to look around in the movie,

but if I look in the back hemisphere, I see half the screen black, half the screen with the video flipped, and if I move my head, the frame remains still.

If I move my head back to front, everything returns fine.

Why is that?

[My Test Project][3]

Hey ocramot!

I’m not sure if this will fix the issue as I don’t have time to test it right now, but I did open your project and notice your Material is only comprised of a Texture Sample node plugged into Emissive Color.

In both these pieces of documentation:

and

the material is either multiplied by 2 or scaled by 2 in the V direction. Maybe that could be causing the issue?

Ok, I found what was causing the issue, even if still I don’t understand why is that caused (not sure if there is a bug that should be reported, and how that happens). Anyway, the problem was caused from the initial fading out from black that I implemented.

Since you can’t use post processing effects right now with UE4 on Gear VR, I used the same technique adopted by the developers of Escape Velocity: Creating Escape Velocity for Samsung Gear VR: A Postmortem - Unreal Engine

So, I had an invisible black box, and at the start of the game i set it to visible, and then with a timeline, I faded it to invisible; then I reset its visibility to false:

(I don’t even know why I am doing the last passage. I supposed that rendering a visible object with 0 opacity took longer than rendering an invisible object).

If I cancel the last passage (setting the cube to invisible), the problem is gone:

Still not sure what’s happening there.

It is important to notice that I have other maps in the game, using the same player pawn, with the same fading-in at the beginning, but with a ‘normal’ environment instead of a sphere with a 360 video; and the problem is not happening there…

Hi dmhwtn, thank you very much for your time! Hm, I might be wrong, but I think that in the first link, the scaling is to ensure that the proportions in the movie respects the proportions in the mesh of the object used to reproduce them. In my case, the mesh is already in the correct proportions to reproduce a 360° video. In the second example, instead, the whole texture is multiplied, probably to make it brighter.

Anyway, I found a solution by myself tonight, see my other answer for that. Thank you anyway for the other useful informations :wink: