3 Questions: Capsule visual | On-Air controls | motion blur... ?

Hey All!

So… I’m messing around with UE4 a bit in order to get into Blueprints.
I’ve managed to make this static mesh cube thing… to move Left, Right and Jump (Yay… I’m such a noob).

So far so good, and now to the problems:

1. In the Viewport, while editing the capsule size, for some reason the capsule size stay like an “onion skin” in 2D Animation.
Everything works fine when I play but, even when I restart the project the capsule is all over the place.

Is this something I did wrong? (I only changed it’s size to fit to the cube, didn’t touch anything else)
Is it my hardware? or maybe a bug?

I’m using the most up to date version 2.7.5 (Latest update from few hours ago within the Launcher)


2. When I click spacebar button to jump, first it didn’t let me move on the air.
for example: if I jump right and on-air I press left.
So I changed the air control to 1, now I can change it only when the character falls.

How can I create a full control not for moving on-air, and not only when the character falls?
Is it inside the Character Movement properties or something I need to do in Blueprints?

3. Is there a way to reduce the amount of motion blur when I move with the camera or moving the character?
I don’t want to turn it off but maybe reduce it to the right amount that I like.

I know that my questions may sound very stupid but I’m very new to UE4 and trying to get used to it by starting simple from scratch empty levels (I just got confused when I looked on the templates…) so I hope you can help me out with step-by-step please or video tutorials so it will be easier for me to follow and understand.

Thanks ahead and sorry about my bad English. :slight_smile:

The onion skin should be normal. Your capsule looks to long in your image. Try shrinking it’s height. That’s probably why you can’t move the cube as the capsule probably get’s caught as soon as you run the game. That may also be the reason it goes crazy as it is colliding once you run the game.

To reduce motion blur you should check your camera setting as shown here. Blueprint Creating a 2D Side-Scroller | 01 | Live Training | Unreal Engine - YouTube Skip to 26:00