Download

2nd Time Blueprints get bugged by theirselfs

Well, I´m working hardly with blueprints, making more or less complex logics, but I think I found the limits of the blueprints for now.

In one of my active projects I experienced a problematic bug, I must say that all was working well before this but I started to see a problem with one mesh collision, I have a box that is hidden with collision off, and in a certain moment, I turn its collision on and unhidde it, well, it was working before, but sudently it stoped to have collision, when, the second box to become unhidde and with collision was working well, after some test I thought that the editor was buggy and restarted it, but when I closed the unreal engine 4 it took a long time to close the window (no program errors or windows errors).

My surprise was that when I started again the program, one of the blueprints got one event outdated and 1 array disconected from this event and from his functions (lenght, clear, …), even if I save it, every time I restart the UE4 I get this connections broken and the event outdated.

But that not all, I experienced that one tag that the parent class had (“Interactable”) and that was working very well before all this situation started is not inheriting on his childs!

The worst point is that I all this things were working well, before I closed the editor, and I did not modified any blueprint before close…

So, please, anyone experienced somethink similar or has any Idea? I tried to make a new blank project and migrate all my blueprints, but the problem is persistent…

Has UE4 some kind of backup code store from blueprints that I can delete to make it recompile all? some kind of cache that keeps the bugs remain?

Thanks all!

PROBLEM HALF SOLVED ON 4.5.1

**Answerhub topic: **Blueprint nodes links break - UE4 AnswerHub

PROJECT FILES DOWNLOAD: https://drive.google.com/file/d/0B8Vq51u7WDypemlsbUhBdHNmLWc/view?usp=sharing
Alert: Note that this files have been tried to be reworked to avoid the issue, so in the original point they were made in other way
Aler2: Do not copy these files to your own project making copy/paste or your project will be infected! the issue is persistent so even if you copy a node it will start crashing

Well, you could use autosaved files. They saved me a lot of times!

Documents\Unreal Projects\Your project name\Saved\Autosaves\Game

You’ll find some autosaved versions, just overwrite your damaged assets in your actual content folder with a backup of your choice.

Thanks for the idea but I had autosave disabled, I usually work very fast and is annoying to me, I manually save all the time and with a loot of frecuency, but I was not expenting a bug of this scale…

It sounds like at least part of your problem is related to circular dependencies. Aside from this, unfortunately, blueprints have numerous hard to replicate issues ESPECIALLY when projects reach a certain size and complexity. I know they are actively working to resolve these issues, but it will take time. You can contact epic, about this by posting to answerhub.

In the interrim, read this thread:

Lastly, another solution is to move your boilerplate functionality to C++ (which is what we did for our project - we were going to do that anyway, but we just had to do it sooner rather than later)

-fisj

I think in this case is related to event inputs that are of type custom BP and get an array from it, anyway, if you try to delete the bad working nodes and variables to try to restore it you are dead because it will start breaking in other nodes randomly and finally it will crash the editor when you try to open any damaged BP

Also, finaly I got an error on the node “get player pawn” that said to contact the framework team because they need to know that bug, this means that is a big internal problem, why? I dont know because deleting it and adding it again it works (for sure, next time I restart the engine it becomes broken again)

I dont like to jump to c++, Im not very familiar with it and would be difficult to port all I did in BPs :S

Thanks for your reply!

OP, I just posted a thread very similar to yours now when I stumbled upon this thread.

While my problem was a character blueprint that has been slowly getting more and more corrupt/crash-prone, I have also seen the exact issue that you are describing (array nodes disconnected on startup). As LHutz mentioned I’ve had to use autosaves frequently to recover from these situations.

I still haven’t managed to figure out exactly what causes the array nodes to be disconnected randomly but I’ve found that adding as many checks as possible (eg: is valid/length>0) seems to help a bit. Also worth reading - Blueprint pitfalls and death traps - Blueprint Visual Scripting - Unreal Engine Forums

Files go bad. Hard disks crash. Computers get stolen. Ideas don’t work out as intended. This is the nature of software development, and you need to always be able to get back to a previous version of anything.

I highly recommend using some kind of source control. Create a git repository at the top of your project, add a .gitignore that excludes all built resources/directories, and then do a git add/commit every so often (AT LEAST daily) to save versions of what has changed. Might want to git push to a remote repository as well, to save against hard disk crashes.

I see that Im not the only one experiencing that, I recovered it from assets autosave, I forgot that I let content autosaves alive (because no alert is shown before the autosave start)

Anyway, Im making a work around with this problem, but basically you have to avoid using this arrays of death.

Should be good that epic guys take a look to this thread

Glad to see that you survived :stuck_out_tongue:

But its an horror, I cannot work like this, even when I did a complete work around the issue, another one appeared, it made an event to get broken in 2 BPs and all child components to get reparented to nothink…

It just gets broken randomly, epic should take an important look to this because there are no end user error there, it just breakes (for example) an event, and the solution is to remove the event node and call it again, it has no sense

Ill upload an screen and some more details later

I have run into this issue before, nodes would spontaneously de-connect themselves upon engine load. I thought the problem was connected to Perforce Source control but apparently that’s not the case. I have a thread on Answerhub but it’s currently unanswered as it seems to be very difficult to replicate. (If you have the project files, definitely send them to Epic so they can look into it).

It also means you cannot compile your game for shipping etc for some reason. The only fix I had was to re-start my project, and copy my nodes over WITHOUT copy-pasting. It was a long-winded and irritating process but I had to admit defeat in the end. I since started learning C++ haha :wink:

Do submit the Project as a Zip to Answerhub (you’ll have to link it from Google Drive or something) if you can, hopefully this issue can be crushed. It’s a complete show-stopper when it happens.

Yes, Ill upload the project and publish it

Anyway, here are some screens, now, the event doesnt breaks, because I added some casts, so now the casts are breaking…

**Question asked here: **Blueprint nodes links break - UE4 AnswerHub

PROJECT FILES DOWNLOAD: https://drive.google.com/file/d/0B8Vq51u7WDypemlsbUhBdHNmLWc/view?usp=sharing
Alert: Note that this files have been tried to be reworked to avoid the issue, so in the original point they were made in other way
Aler2: Do not copy these files to your own project making copy/paste or your project will be infected! the issue is persistent so even if you copy a node it will start crashing

Hi,

just wanted to add that I too have this problem. My faulty Blueprints got migrated from 4.4.3 to 4.5 - I had no issues before.
One Bleuprint is randomly loosing the connection from one Float value. I have saved it a dozend times correctly and after a while (Editor restarted or something) the connection gets lost again. Very annoying!

I added the project files and made an answerhub thread so I hope Epic guys take a look into this important problem early, but when more people vote and comment in this thread and in answerhup saying that they have this problem also, more speedfull will they solve the problem

Yep, identical to the issue I was having. I was trying to cast from GameMode if I remember correctly.

Much earlier on in the engine, I was having this issue:
https://answers.unrealengine.com/questions/69548/blueprint-changes-everytime-i-open-my-project-caus.html

This. Pretty much all my BP corruption woes began when I started casting from GameMode (I was using my custom game mode to store some global game data)

Nesjett, which version of UE4 are you using though? As I just replied in my related thread my corrupt blueprint issue seems to have been fixed after I migrated to 4.5!

Hey guys,

Thanks to everyone for all of the information you’ve provided. This has been difficult to track the cause of this problem but with the help of Nesjett submitting his project we can look into what is causing this to happen. It has been submitted to our tracking system for further investigation.

Cheers

The first time I got this problem was on another project, and was on a cast to my custom HUD (If I remember it well), but now is on another locations.

Thank you very much Doug Wilson for your time, if the Epic team needs more info I have the originaly “infected” files of the project, and another old project (but in 4.4.3) where I experienced it too.

Anyway, I just updated to 4.5.1 and in some hours Ill report here if the problem is solved.

Feel free to continue posting issues or comments about this issues here, when more feedback or ideas are provided earlier it will be solved

Hey guys, seems that problem is solved on 4.5.1

I have not tested it with time, but atleast this nodes have been recovered automatically

If someone still have issues would be good to know

For the record:
https://answers.unrealengine.com/questions/123934/blueprint-looses-connection-every-time-editor-rest.html

Everybody with bugged Blueprints should check the names of functions and test them with all lowercase characters.