2D Pixelart game Blurry While Running (SOLVED)

Hello, I have the following problem that when I start running everything in my game becomes very blurry. Can someone help me and explain how to solve this?

Hi @ZimMabu1992

The graphic from the stand still and then in motion look fairly close to me. Is it something you’re only seeing when the level is in motion/animated or does it occur on standstill as well?

1 Like

hey, thank you very much for the answer, I’m really desperate, the whole thing only happens when I’m moving, when I stay still everything looks perfect

Anyone a idea :(?

Do you have some type of anti-aliasing enabled or something of that nature? Normally blurring doing movement is almost always from AA unless it’s something like screen tearing or an issue with shadows. If you have any type of AA enabled, try disabling and retesting.

1 Like

i use the project settings from cobra code
Bloom is also disabled

i made a new record to see why the screen goes to be so blurry
its now on slow motion something realy strange happend with my tilesets but WHY?
it flickers
I mean look at the grass on the ground there u can see it as best

That is indeed pretty strange. Does it occur if you disable the shadowing?

1 Like

yep still the same i turn the shadows off :frowning:

Do you happen to have your frames locked to your display rate, by chance?

1 Like

You see it looks realy laggy and shi**** but i dont know why i have a very strong pc i can play all of the new games with highest quali so im realy sad about all of that

60 fps?
you mean that right with display rate

Your texture buffer could be set to low for texture streaming so try turning it off. We had the same problem as the textures tend to get mip mapped. By turning it off we were able to remove the blur and isolate the problem

1 Like

do you know where exactly i can find it?
i just see that under “texture streaming”

I believe Frankie was referencing to turn off the texture streaming from the check box there at the bottom. Here’s a list of .ini edits/commands that may be of use as well. Texture Streaming Configuration In Unreal Engine | Unreal Engine 5.4 Documentation | Epic Developer Community

1 Like

thanks the texture streaming is now off
it improved the graphics significantly :smiley:

Awesome! I’m glad you got it fixed!

1 Like