2738 Error code installing Launcher. Help please!

The launcher gets past copying new files and then fails with the popup error message.

Here is a Log;


=== Verbose logging started: 14/03/2015 03:36:15 Build type: SHIP UNICODE 5.00.7601.00 Calling process: C:\Windows\system32\msiexec.exe ===
MSI (c) (BC:94) [03:36:15:182]: Font created. Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg

MSI (c) (BC:94) [03:36:15:182]: Font created. Charset: Req=0, Ret=0, Font: Req=MS Shell Dlg, Ret=MS Shell Dlg

MSI (c) (BC:2C) [03:36:15:182]: Resetting cached policy values
MSI (c) (BC:2C) [03:36:15:182]: Machine policy value ‘Debug’ is 0
MSI (c) (BC:2C) [03:36:15:182]: ******* RunEngine:
******* Product: C:\EpicGamesInstaller.msi
******* Action:
******* CommandLine: **********
MSI (c) (BC:2C) [03:36:15:182]: Note: 1: 2203 2: C:\EpicGamesInstaller.msi 3: -2147287038
MSI (c) (BC:2C) [03:36:15:182]: MainEngineThread is returning 2
=== Verbose logging stopped: 14/03/2015 03:36:15 ===


Someone help please.

Also opening the msi in winrar immediately prompts that its corrupt. i have redownloaded several times and had the same occurance. also followed other similar posts/threads.

Hi omar_0007,

The 2738 error is some sort of permissions error that users have had issues with in the past. Here is the a post that has a lot of troubleshooting steps that may help you with the issue. If nothing works, post back here and we will help you investigate the issue.

Hi TJ,

Thank you for getting back to me. I have been through the post trying everything from using the tools to uninstall mcafee and mirosoftfixit. Also did the unregister and reregister command prompt. Lastly just tried the whole Registry Key editing. I still have the same issue.

Would love further assistance.

I’m not sure how you generated the initial log snippet you posted, but perhaps you could follow the steps outlined here to get installer logs: LINK

If they are too large to post here, you can zip them up. These logs should help us narrow down your issue.

Thanks for replying!

I have used the method you have given in the suggested link and i get an error as shown in the image below.

34457-epiclauncherror.jpg

The log in the original post is all I manage to get.

Can copy/paste the commandline that you were using? Often times we see that there is a missing msi file extension or missing/extra spaces in the command when errors like this appear.

sure, here is what i used;

msiexec /i C:\EpicGamesInstaller.msi /L*V C:\EpicGamesInstallerLog.txt

What is the file name of the installer you downloaded, and what folder is it in? The error dialog you are seeing pops up when the msi you passed in to msiexec is not found. Is your installer actually located on your C: drive here: C:\EpicGamesInstaller.msi?

Right, thanks. The file name was different. Apologies, my bad.

Here is the log I got now. See attached file.link text

Interesting, the same VBScript custom action that is failing in this thread (LINK) is failing for you but with a different error code. Try the workaround steps I posted in the linked thread.

Well that worked perfectly! THANK YOU!!!
you are all very much loved. appreciate the amount of help you are giving to everyone with issues. thanks again.