2 Abilities, 1 button

I have two abilities, and I want them both to activate/deactivate at the same time with 1 button (E Key). Right now they activate 1 at a time with each press of the button. (E Key.) Does anyone know how to fix this? Posting screenshot of both abilities in blueprints (picture of blueprint.)

Select one of those E nodes, in the details, uncheck ‘consume input’. Do the same for the other :slight_smile:

Didn’t work, they’re still activating/deactivating one at a time.

That means you have an E key node somewhere else that’s consuming the input. To be sure, just change the key to Z or something you defintely aren’t using…

Simply use the E Key output and use a Sequence to run both of them from the same button. A sequence will be simultaneous.

Just tested with multiple keys. Still doing the same thing. No change

@Keytotruth Tried that. Now they’re switching from one another with 1 key press. Not exactly activating at same time.

I should say that both abilities are connected with the postprocess volume

It’s to do with the PP, I see it also…

It’s because you have two TLs running at once. Although one of them is trying to adjust a param, the other one is holding it on zero.

You need to do it in one TL

Like this:


Like this:


Sorry for this noob question. But how did you get the “SET” and “PostProcessVolume” blueprints in top right corner? Can’t seem to find them.

No worries. That was a level BP, so I clicked the PP in the level and went to the BP, right click on the background and the variable will be at the top of the list. If you have a BP actor containing a PP vol, obviously it’s different, but similar.

Once you have a ref to the PP, just drag a pin off and you’ll find the mysterious ‘set settings’.

Right click on the graph background to get ‘make post process settings’ and then look in the details to tick the ones you’re interested in.


Alright sorry. I have everything except for that “SET” node, that the timeline (UPDATE) and PP is connect to. How do I get that? THanks in advance lol

The SET node that is in the very top right, and right below the post process volume bp

Just pull a pin from your PP reference and look for ‘set settings’

Sorry, thought I’d answered this. Pull a pin from your PP reference and look for ‘set settings’

You did. I’m just stupid lol. Thanks a lot. Still not working, but I did figure out some other stuff while I’ve been messing with it.