Download

1d animation blendspace for walk-run creates shicken steps near 0 speed

So I have this simple issue. Near 0 speed the legs do these short chicken steps:

That gif is recorded from my 1D blendspace where I move the speed from 0 to maximum (from idle to walk to run) and then back to 0. In my animation blueprint I’ve set minimum speed to 10. I have three animations set up: one for idle, one for walk and another for run. Plus the same for rearwards movement.

Is there way to control how the animation blends from idle to walk so it takes longer steps? My assumption here is that because it linearly interpolates between stationary and walk all the animations are scaled from 0 to 1 between those two states for every speed. Is there way to make that interpolation nonlinear for example? Or use some other technique?

Or do I just need to make new animation for really slow speeds (which is two animations, one for forward, another for backwards movement)?

So I made a slow walking animation but I still have this exact same issue. Converted to 2d blendspace and same issue.My character has a vehicle like backwards/forwards movement so the character gradually builds speed.

How do I get the animation to run slower but no scaled in motion for really slow speeds? Scaled in speed only, not motion?

Just like I said my post above. My assumption here is that because blendspace linearly interpolates between animations it scales both the speed and motions of the animations. So if my animation is set to speed 1 and my character takes steps that are say 100 units long. How do I get it that at 0.5 speed my character still takes 100 unit long steps but the animation just plays slower?? I’m trying to look at the various options but I’m a bit overwhelmed and I’m clicking lots of stuff that I don’t know what it does or why it doesn’t do anything.

Have you solved it? I’m having the same situation and I can’t find any explanation for it.