100% blueprint project corrupted

When I last used the editor the entire project compiled and saved fine then I started it up again the next day and everything is (Bad word) up.

Here is my project

To break it just try to open the game mode I haven’t tried to open everything but everything I tried to open broke the engine.

I’m pretty sure the problem is something to do with UMG because I have had this same problem 5 or so times and every time it happens the last thing I was working on was something with UMG.

Your link is just a png picture. =)

Fixed. soz for that
I clicked share on wrong thing

Hello AlphaSierra216,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints that may be involved with this issue(cannot open blueprints in provided project)?
  4. Can you provide any code changes that you may have made to the project?

Hey.
I tried to reproduce it for a couple hours and the only way it gets reproduced is if I copy the entire content folder to a new project.

I have narrowed the problem down to the “Perk”(Content\Classes\Misc\Structs) struct, when I remove that everything is fine except for the broken references to it.
one way that this struct is special is that it is an array inside another custom struct.
Another way is that it had a reference to a class that had a reference to this same struct.

Sorry I cant be more help

Hello AlphaSierra216,

If you recreate the “Perk” system in a clean project does that recreate the crash?

I did as you asked but it still wont crash, I even tried to spazz out with interdependence’s to a tonne of things but it still wont crash.

Hello AlphaSierra216,

Now that you have remade the perk system, are you still experiencing this issue?

Not in a clean project I don’t.

Hello AlphaSierra216,

So if you replace the perk system (struct) within your actual project, you still receive a crash? I was able to remove the perk system from the project that was provided and then replace it with a new version of it. This stopped the project from crashing and does not appear to be throwing any errors.

Yes if I replace the struct with a new exact same one everything becomes fine again. for now.

Hello AlphaSierra216,

I am happy to hear that we have found a workaround for your issue. I did a big more digging on this crash and it appears that you are the only one reporting this crash. This means that this issue is most likely specific to your project. There may have been a corrupted node that was causing this issue that was replaced after switching out the structs (one way corruption can occur is when upgrading a project). I hope that this information helps. I am going to accept your last comment as the answer to this issue. If you experience this issue again please feel free to reopen this issue with any additional information you have and any steps needed to reproduce it in a clean project. Thank you for your time and information.

Make it a great day