0 succeeded, 2 failed, 3 up-to-date, 0 skipped

When using visual studio 2015 to build UNREAL ENGINE 4
I get Output.txt in output of visual studio
and get ErrorList.txt in error list of visual studio

Hey Zeyad’Gamer,

The message “Please verify that you have sufficient rights to run this command.” can come from two things.

The first, do you have two versions of Visual Studio running open with the same project?

The second reason is much more difficult to figure out as it can from from using some code without including the proper header files. As an example, you can get this error if you are using multiplayer functions in an Actor without include “Net/UnrealNetwork.h”.

With this in mind, can you post anything regarding your project? Specifically, anything related to what portions of the engine you are using.

You can also post code samples if that helps you get the point across.

Thanks.

  1. I don’t have two versions of Visual
    Studio running open with the same
    project
  2. can’t build Unreal Engine 4 to make
    project

Could you try opening Visual Studio by right clicking the Visual Studio 2015 shortcut and selecting “Run as Administrator”.

If your user account on Windows is not an Administrator you will sometimes get errors like this when an application needs sufficient rights to create files in some locations.

If running as administrator works and you own the computer (or are allowed to do so by your company/school) go to Control Panel → Users and change your account to an Administrator type. This way you won’t need to run as administrator every time.

Hope that helps!

EDIT: Also @Tim Lincoln asked you on the other duplicate question which branch you are using. When you downloaded the source from GitHub were you using the Release branch, 4.12, 4.13, Master, or another branch? If you did not switch branches, you would have downloaded the Release branch by default. Could you please confirm this for us? Thanks!

  • I didn’t use any tags I downloaded
    the source code as zip file

  • I didn’t had any problems when
    running Setup.bat or
    GenerateProjectFiles.bat

  • Solution Configuration Development
    Editor

  • Solution Platform win 64

  • Visual Studio 2015 Community Update
    3

  • Unreal Engine 4 source code 4.12

I was already aware about this post on the duplicate question, you didn’t need to paste it here again. Could you please reply to the questions in my post above? They were:

  1. Did you try run as administrator and then build?

  2. When you downloaded the source code did you switch branches first or just download?

Question 2 might seem trivial, but there is a difference between the Release branch (default) and the 4.12 branch. Specifically an issue with Visual Studio 2015 Update 3 was fixed in a hotfix for 4.12, I am not positive it is in the release branch (4.12 branch is newer).

Thanks

  • I tried to run as administrator and build but
    same output
  • I switched the branches to 4.12

Are you having this issue on a specific project, as in a project that you’ve been working on? Or, does this happen for any project you create with UE4?

Can’t build Unreal Engine 4 first to make a project

Hey Zeyad’Gamer,

In the first log file, you have a error: Failed to open/create session data: STATUS_ACCESS_DENIED.

I looked this up and it has to do with Visual Studio not being able to create a session to a remove client.

Can you first make sure you are logged into your Microsoft account when running Visual Studio 2015.

Secondly, can you run Visual Studio 2015 in Administrator mode? You can do this by right clicking on the Visual Studio 2015 exe and choosing, “Run as Administrator”.

Then, try to compile UE4 again.

I am sure visual studio logged in my Microsoft account

Visual Studio 2015 in Administrator mode but after run Visual Studio 2015 in Administrator mode have this log 1 when trying to build unreal engine 4 and when try to build unreal engine 4 again have log 2 which is not the same log 1

It states in your log that it can’t connect to the XGE server.

Distributing 96 actions to XGE
4>EXEC : Fatal error : Failed to initiate build.
4>  Failed to connect to Build Service (on local machine): Server is not reachable

Perhaps you can look at fixing that first? Try disabling it.

Hey Zeyad’Gamer,

Can you see if you have a program called “Incredibuild” installed?

If you do, please uninstall it, restart your computer, and then try to build UE4 again.

thank you very much my problem is solved