Download

0% Lighting Progress, 0% Build Progress after nearly 45 minutes...

My build times and lighting times are crawling. I know this is a common complaint and has been since UE3 & Even UE2 (to some extent).

Anyways, I’ve adjusted the lighting settings, adjusted the lightmass settings & optimized my machine. I’ve followed the unrealengine wiki guides on this topic.

My map is somewhat large (a single outdoor scene large enough for 8-12 players) but not nearly as complex as the one in the example here:

https://docs.unrealengine.com/latest/INT/Engine/Rendering/LightingAndShadows/Lightmass/index.html#gettingthebestlightingbuildtimes

In my lightinginfo panel it says my total lightmap memory usage is roughly 10,000kb & 5,000kb, respectively. It shouldn’t be taking this long. I’ve used a lightmass importance volume of course.

Is there anything else I can do?

How long should I expect this to actually take?

Is your CPU running at 90%+ in task manager? What CPU do you have?

Lightmass is a very CPU intensive process and can take a while depending on the number assets in the scene and system specs. Large scenes can take an extraordinary amount time depending on these factors, especially for a single machine. While it may be a common complaint, it’s hard to get around all the calculations that need to be done for accurate shadows and GI to be baked. You can always lower the quality settings in the World Settings > Lightmass tab.

If you want quicker build times, it’s better to use a smaller scene, reduce the number of objects, and lower lightmap resolutions to start with.

Larger scenes will typically use dynamic lighting in lieu of baked lightmaps. The texture memory used for storing the lightmaps can become higher for larger scenes. With 4.8 there has been a push to make larger worlds easier to create and better with performance with a large number of objects and using dynamic lighting.

Or use multiple computers with swarm agent to speed up the process :slight_smile:

You can also check your memory usage. If Lightmass is using all your memory it can slow down a lot (probably swapping or something…)

Can you explain me how to achieve this? or point me to a step by step tutorial?

Thanks in advance.

Its comparable easy to set up. You need to run the SwarmCoordinator on your initial PC and the SwarmAgent on your render slaves and tell the coordinator to use your slaves via IP. Check out this documentation for UDK, it works identical for the UE4:

http://udn.epicgames.com/Three/DevelopmentKitContentCreation.html#Swarm%20Setup

And here is another tutorial with a better step-by-step explanation plus pictures:

http://www.froyok.fr/tuto_swarm_en.html

You’ll find both executables under \Unreal Engine\4.X\Engine\Binaries\

All machines must have UE4 installed? or i need it only on coordinator machine?

Many many thanks!!!

Thanks Tim. I’ll do the suggestions you mentioned. I actually DON’T want high quality lighting. UE4 seems to assume that I do. I just need enough to cast sunlight on my map. That’s it.

I’ve already dropped lightmass settings to preview & adjusted static mesh resolution and it is still taking this long. I’ll remove objects see if that helps. Are there any other quality settings I can drop? Any way to force the load over the the GPU?
Also, I’ll try loading 4.8 see if that helps.

What processor are you using? How many assets? What resolution are you light maps? The Koola scene from the community examples only takes about a minute to generate lightmaps set to production quality, so I’m just trying to figure out if there’s one thing that’s causing it to take much longer than normal.

Amd A10 2.5Ghz Quad Core
2x ATI Radeon 8670, 2GB
8GB Sys Ram
Clean, defragged, etc.
Plenty of HDD space.

675 objects/actors in scene. Just did some cleanup prior to posting this msg.

*Update. Light rebuilds are fast now, oddly enough. I had to remove foliage completely in order to do it, and drop the lightmap resolution on all objects down to a very low number. Hm.

But map is all dark on my landscape.:

and the Cooking process is taking quite some time…

Super huge major mega thanks to everyone’s help thus far on all of my questions, by the way. Mango drinks all around!

Apparently no, just copy the DOTNET folder from /epicgames/4.7/engine/binaries to each of your computer. This folder contains the swarmagent.exe and swarmcoordinator.exe.

On a big scene you can expect huge build times. Hours isn’t uncommon on a regular pc.

@Vindkald

Apparently no, just copy the DOTNET folder from /epicgames/4.7/engine/binaries to each of your computer. This folder contains the swarmagent.exe and swarmcoordinator.exe.

On a big scene you can expect huge build times. Hours isn’t uncommon on a regular pc.

@Phil, to be clear, this is for packaging the project into an external build, NOT lighting, correct?

packaging is taking a while for me, lighting does not.