User Tag List

Page 6 of 7 FirstFirst ... 4567 LastLast
Results 201 to 240 of 269

Thread: Unreal Engine 4.15 Preview

  1. #201
    0
    Champion

    Join Date
    Mar 2014
    Posts
    780
    Physics problems added in the 4.14 keep there just awesome

    https://answers.unrealengine.com/que...es-broken.html

    Now are even worst and this is not even the vehicles code... the only physics part here is the chasis is really sad UE4 can't handle 2 cubes colliding...
    Hevedy - Image Tools: https://hevedy.itch.io/imagetools

  2. #202
    0
    @Hevedy What's the mass of your car and the cube it's hitting ?

  3. #203
    0
    Can't join LAN Session in 4.15. Session is being created, but clients can't join it. Launching 2 PIE clients works (of course, because they are starting already connected to each other).
    Might be my own mistake, I'll mess with it more tomorrow.

  4. #204
    0
    Quote Originally Posted by JoeWintergreen View Post
    I just want to draw some more attention to this. A lot of us have been waiting on it since forever. Data tables are way less useful without it.
    And even more attention, please. I have a huge Narrative AI project just waiting for data table improvements.

  5. #205
    0
    Champion

    Join Date
    Mar 2014
    Posts
    780
    Quote Originally Posted by motorsep View Post
    @Hevedy What's the mass of your car and the cube it's hitting ?
    Is not a vehicle of Epic, is a complete new vehicle only the chasis is physics cube, happen too at touch the ground not the cube, works before 4.14, in 4.13 worked, since the PhysX update all is broken...
    You can check the link is the complete project.
    Hevedy - Image Tools: https://hevedy.itch.io/imagetools

  6. #206

  7. #207
    1
    Champion

    Join Date
    Mar 2014
    Posts
    780
    New Tonemapper just impossible get any blue, all is purple Really ?

    And Epic mark it as "By Design", next version 4.16 just turn all black/white by design.
    Last edited by Hevedy; 02-06-2017 at 09:10 AM.
    Hevedy - Image Tools: https://hevedy.itch.io/imagetools

  8. #208
    1
    Quote Originally Posted by Hevedy View Post
    New Tonemapper just impossible get any blue, all is purple Really ?
    Yeah, do r.Tonemapper Film 0 and you are back to the old one with correct colors.
    Easy to use UMG Mini Map on the UE4 Marketplace.
    Forum thread: https://forums.unrealengine.com/show...-Plug-and-Play

  9. #209
    0
    Unreal Engine Developer
    Join Date
    Mar 2014
    Posts
    1,119
    Quote Originally Posted by zeOrb View Post
    Hey,

    Any comment on Tonemapper changes?

    https://answers.unrealengine.com/que...es-in-415.html
    Hi all.

    Changes to the tonemapper in 4.15 are intentional, and provide a more physically accurate behavior. The old approach can still be achieved by setting r.TonemapperFilm 0, but this may not be supported in future versions.

    Full details about the changes will be available in the full 4.15 Release Notes.
    Stephen Ellis | Lead Engine Support Technician | Epic Games | @TheEpicStephen
    How to report a bug | >>Click here to report a bug<<

  10. #210
    0
    Luminary

    Join Date
    Mar 2014
    Posts
    1,940
    Quote Originally Posted by Stephen Ellis View Post
    Hi all.

    Changes to the tonemapper in 4.15 are intentional, and provide a more physically accurate behavior. The old approach can still be achieved by setting r.TonemapperFilm 0, but this may not be supported in future versions.

    Full details about the changes will be available in the full 4.15 Release Notes.
    Hello Stephen!

    Please, check post I linked. It's not about Tonemapper film, it's about other ones

  11. #211
    0
    Unreal Engine Developer
    Join Date
    Mar 2014
    Posts
    1,119
    Quote Originally Posted by zeOrb View Post
    Hello Stephen!

    Please, check post I linked. It's not about Tonemapper film, it's about other ones
    Our support team will look into it and follow-up on the Answerhub. Thanks
    Stephen Ellis | Lead Engine Support Technician | Epic Games | @TheEpicStephen
    How to report a bug | >>Click here to report a bug<<

  12. #212
    0
    Luminary

    Join Date
    Mar 2014
    Posts
    1,940
    Quote Originally Posted by Stephen Ellis View Post
    Our support team will look into it and follow-up on the Answerhub. Thanks
    Thanks, really appreciate that!

  13. #213
    0
    Quote Originally Posted by Themanwithideas View Post
    Thanks! Interesting read

  14. #214
    0
    Infiltrator
    Join Date
    Aug 2015
    Posts
    16
    No luck getting the RawInput plugin working. Details in https://forums.unrealengine.com/show...t-Plugin-error

  15. #215
    0
    I tested and it seems Light Functions are now working with the Forward Renderer? Can someone from Epic confirm this? If so, why is it not in the fixes list? Thanks!

  16. #216

  17. #217
    1
    Quote Originally Posted by diamond3 View Post
    Can't join LAN Session in 4.15. Session is being created, but clients can't join it. Launching 2 PIE clients works (of course, because they are starting already connected to each other).
    Might be my own mistake, I'll mess with it more tomorrow.
    LOL that was not a bug but rather a fix . Now 4.15 takes into account 'Public Connections' value for LAN sessions. I used to keep its value as '0' in 4.14.

  18. #218
    0
    I tried vehicle plugin it looks like roll back to wrong CenterOfMass setup before 4.14, which means car moving like solid box once again. I mean in 4.14 you got :
    "We’ve changed where tire forces are applied. Previously, tire forces were applied at the vehicle’s center of mass. We now apply force at the tire’s center of mass which makes it easier to achieve load sway in cars."
    Now it looks like 4.13 again, maybe i'm wrong I'll do more tests. Cheers

    ------------------

    OK I figured out somehow that I must derived a BP car from cpp class, explicitly toggle the "deprecated spring offset mode" twice(check, uncheck), then it all works. If i use cpp vehicleAdv template directly in game, the car just stick with deprecated mode, and no way to change unless I hack engine/plugin, no ideal why. Maybe ue4 serialize function think the car is current version only after I do these? Anyway it won't stop me enjoy 4.15~~
    Last edited by takistudio; 02-07-2017 at 06:50 AM.

  19. #219
    0
    How does the Blend Space editor work now? I have a Blend Space in there but I can't move my mouse around the grid to see the results?

    EDIT: I figured it out! You hold Shift while hovering over the blend space. Maybe make this more visible in the future please? Thanks Epic, keep up the good work!
    Last edited by KoldKam; 02-07-2017 at 01:32 AM.

  20. #220
    0
    Promoter
    Join Date
    Jan 2015
    Posts
    177
    Quote Originally Posted by Stephen Ellis View Post
    Our support team will look into it and follow-up on the Answerhub. Thanks
    Hello Stephen,

    Anything being done on https://issues.unrealengine.com/issue/UE-36879 VOIP has been an issue for a few engine releases now it seems. I noticed Conan is having VOIP issues too!

  21. #221
    1
    Unreal Engine Developer
    Join Date
    Mar 2014
    Posts
    1,119
    UPDATE!

    We have just released Preview 4 for 4.15! Thank you for your continued help in testing the 4.15 build before its official release. As a reminder, the Preview builds are for testing only, and should not be used for the active development of your project.

    For a list of known issues affecting this latest preview, please follow the links provided on the first post in this thread.

    Cheers!

    Fixed in Preview 4 - CL 3286799

    Fixed! UE-41213 Persona - Scene Setup not working correctly
    Fixed! UE-41389 Crash in Skeletal Editor due to null ActorFactory reference
    Fixed! UE-41376 Pitch and LPF parameters updated incorrectly in audio mixer
    Fixed! UE-41377 Audio device hot swap fails for extreme audio device ranges
    Updated! UE-41450 PhysicsBall BP not updating location with Collision volumes
    Fixed! UE-41497 Illegal Else Without Matching If
    Fixed! UE-41474 Putty directory is missing from \Engine\Extras\ThirdPartyNotUE\ in binary builds from the Launcher
    Fixed! UE-40740 Unable to escape from the truck in PlatformerGame
    Fixed! UE-38060 Ribbon Trails are inconsistent in Content Examples
    Fixed! UE-41353 MatineeFightScene too dark due to tonemapperfilm changes
    Fixed! UE-41368 Subway Sequencer too dark due to tonemapper film changes in 4.15
    Fixed! UE-41360 Incorrect camera starting position in PlatformerGame
    Fixed! UE-41359 Crash in FTickFunction::RegisterTickFunction
    Fixed! UE-41333 [CrashReport] UE4Editor_AssetRegistry!FAssetRegistry::GetSubClasses() [assetregistry.cpp:2803]
    Fixed! UE-41339 Second Controller input not recognized on console
    Fixed! UE-41298 iOS Device displays textures darker than in Editor
    Fixed! UE-41498 PS4 differential patch size is abnormally large
    Fixed! UE-41565 Movie playback not keeping texture filtering settings when switching contexts
    Fixed! UE-40779 Crash occurs with PlatformMediaSource called in infinite loop
    Fixed! UE-40063 Crash when a material with a texture parameter is deleted when it has instances with static permutations
    Fixed! UE-41283 Engine Scalability view distance settings are not being reflected accurately in the viewport
    Fixed! UE-41380 Clicking reimport on a skeletal mesh crashes the editor - UE4Editor_Engine!USkeleton::GetSmartNameContainer() [skeleton.cpp:1410]
    Fixed! UE-41496 QAGame Controller Loses Focus on Edge of Viewport
    Fixed! UE-41113 Widgets can no longer take focus after clicking somewhere other than the widget itself
    Fixed! UE-41495 Crash setting actor rotation via details panel in VR editor

    REMEMBER: Please report any new bugs you find by following the How To Report a Bug Guide
    Last edited by Stephen Ellis; 02-07-2017 at 12:46 PM.
    Stephen Ellis | Lead Engine Support Technician | Epic Games | @TheEpicStephen
    How to report a bug | >>Click here to report a bug<<

  22. #222
    0
    Champion

    Join Date
    Mar 2014
    Posts
    780
    Quote Originally Posted by Stephen Ellis View Post
    UPDATE!

    Fixed in Preview 4 - CL 3286799

    Fixed! UE-41450 PhysicsBall BP not updating location with Collision volumes
    Well at this point this is why there are more problems than expected ones. You guys say this is fixed https://issues.unrealengine.com/issue/UE-41450 "Fixed! UE-41450 PhysicsBall BP not updating location with Collision volumes"
    Anyone can check you changed in the repo first comment all and wrong https://github.com/EpicGames/UnrealE...f5e41b638d59fe
    and later you guys come back and remove the comment https://github.com/EpicGames/UnrealE...459e8c80b8834c
    at the end you have the same code of the start and you guys just commented the LOG Warning, mmm sorry ?

    So the log says anymore there is not problem, marked as fixed ?
    And is not the first time I see this, at this point idk if is a communication problem or is other kind of problem...

    Correct me if I'm wrong but is all the changes I see, a commented LOG warning and marked as fixed in public.
    Last edited by Hevedy; 02-07-2017 at 12:02 PM.
    Hevedy - Image Tools: https://hevedy.itch.io/imagetools

  23. #223
    3
    Unreal Engine Developer
    Join Date
    Mar 2014
    Posts
    1,119
    Quote Originally Posted by Hevedy View Post
    So the log says anymore there is not problem, marked as fixed ?
    And is not the first time I see this, at this point idk if is a communication problem or is other kind of problem...

    Correct me if I'm wrong but is all the changes I see, a commented LOG warning and marked as fixed in public.
    You are correct that on further review this one is not fully "fixed", and there may be others in the same situation. Sometimes solutions to bugs are incremental, and may begin with changes to logging before future fixes occur.

    The failure in having it listed as "Fixed" is, as you say, a communication one. The above list comes from a data export of updated tickets from JIRA. Unfortunately JIRA doesn't have a concept of "partial fixes", so these get included. Ideally it would be nice to review each code change to verify that an actual fix was made before being added to the list, unfortunately that is not feasible for us when we have some updates as large as this one.

    We provide as much information around updates as we can, but that can lead to cases like this. However with the combination of our public JIRA site and access to Github, we have tried to empower our users to access the information that is important to them.

    Cheers
    Stephen Ellis | Lead Engine Support Technician | Epic Games | @TheEpicStephen
    How to report a bug | >>Click here to report a bug<<

  24. #224
    0
    Quote Originally Posted by Hevedy View Post
    Physics problems added in the 4.14 keep there just awesome

    https://answers.unrealengine.com/que...es-broken.html

    Now are even worst and this is not even the vehicles code... the only physics part here is the chasis is really sad UE4 can't handle 2 cubes colliding...
    Hm. This was 4.13
    https://www.youtube.com/watch?v=2XANPekrCiI

    Similar glitch.

  25. #225
    0
    Regarding issue UE-41065


    Quote Originally Posted by John Alcatraz View Post
    Yeah, that can't just be "by design" since it breaks all current content. If it is by design, then at least every material needs a checkbox where you can check if you want this new behavior where an emissive blue is getting purple and later white, but that checkbox should be disabled by default for every material that was created before 4.15.



    But it is an issue because of how it works, you can no longer get the look you had before. It is impossible now to get any saturated color that's causing a lot of bloom. For that it has to be multiplied by ~20, but once you do that with any color its just something like white. So you can't have a strong glowing blue or red material now, they will no longer be blue or red.

    So the issue is not only that you would have to redo all your materials, but also that its impossible to get the look you got before.
    So has anybody managed to get the old look (a nice saturated color glow with bloom) back? The recommended r.TonemapperFilm 0 is not doing it for me - any other values I have to tweak? I can't imagine that it is an intended change to make nice glowing materials impossible...
    Last edited by necspenecmetu; 02-07-2017 at 06:30 PM.

  26. #226
    0
    Quote Originally Posted by necspenecmetu View Post
    So has anybody managed to get the old look (a nice saturated color glow with bloom) back? The recommended r.TonemapperFilm 0 is not doing it for me - any other values I have to tweak? I can't imagine that it is an intended change to make nice glowing materials impossible...
    r.TonemapperFilm 0 works fine on my project and others have confirmed the fix.

  27. #227
    0
    Quote Originally Posted by Gwenn View Post
    r.TonemapperFilm 0 works fine on my project and others have confirmed the fix.
    Ok thanks, then I will try it again and if it doesn't work post the scenario in the answerhub thread.

  28. #228
    1
    Promoter
    Join Date
    Oct 2015
    Posts
    215
    Quote Originally Posted by Hevedy View Post
    Physics problems added in the 4.14 keep there just awesome

    https://answers.unrealengine.com/que...es-broken.html

    Now are even worst and this is not even the vehicles code... the only physics part here is the chasis is really sad UE4 can't handle 2 cubes colliding...
    We've dealt this numerous times in Unreal Slackers and also mentioned here in forums. This bug is most likely cause of bad project upgrade and corrupted data due to it. I have no idea why that happens but it doesn't happen to me on that same project IF I upgrade it myself (I see some of the issues with Hevedy's version). I've sent Hevedy updated builds for the same project, both for 4.14 and now for 4.15 and he can't reproduce the issues with version I've upgraded.

  29. #229
    0
    In App Purchase seems to not work in iOS? I posted in answerhub no one answer and tested. Please check...

    https://answers.unrealengine.com/que...in-415-p2.html

  30. #230
    0
    Unreal Engine Developer
    Join Date
    Mar 2014
    Posts
    1,119
    Quote Originally Posted by dizzynoob View Post
    In App Purchase seems to not work in iOS? I posted in answerhub no one answer and tested. Please check...

    https://answers.unrealengine.com/que...in-415-p2.html
    We are investigating this. Your regular "bumps" actually caused a delay because the posts cause the 'activity date' to update, while we investigate the queue from oldest to newest. For this reason, we strongly advise against "bumping" bug reports.

    Thanks
    Stephen Ellis | Lead Engine Support Technician | Epic Games | @TheEpicStephen
    How to report a bug | >>Click here to report a bug<<

  31. #231
    0
    Loving these compile times! Keep up the good work.

  32. #232
    0
    Is release going to happen in a couple of weeks ?

  33. #233
    0
    Unreal Engine Developer
    Join Date
    Mar 2014
    Posts
    1,119
    Quote Originally Posted by motorsep View Post
    Is release going to happen in a couple of weeks ?
    Sooner than that, if all goes well.
    Stephen Ellis | Lead Engine Support Technician | Epic Games | @TheEpicStephen
    How to report a bug | >>Click here to report a bug<<

  34. #234
    0
    Oh god... Wait till next month, my data plan is already almost capped for the month
    * that moment when all your dcc tools licenses fails and you have to download all of them to reinstall again*

  35. #235
    0
    Quote Originally Posted by JamesG View Post
    Hopefully it should be a pretty easy transition. The plugin is enabled by default, but if you are using vehicle classes in C++ you will need to add a dependency to the PhysXVehicle module to your Build.cs file, so the build system knows about it. The only thing that might need manual work is converting from TireType to TireConfig assets. Here are my draft notes on the topic:

    Note: a manual step is required if you want to migrate old ‘TireType’ assets (deprecated in Engine) to the new ‘TireConfig’ assets (defined in the new PhysXVehicles plugin). There is a new console command available in the UE4 Editor that will do this for you - simply summon the console and enter ‘ConvertTireTypes’. This will create new TireConfig assets, copy over properties, and assign them to any VehicleWheel Blueprints. The old TireType assets can then be removed.

    In the old system the PhysicalMaterial had a list of TireTypes and their friction scale. Now the TireConfig has a list of PhysicalMaterials with friction scale for each. This is because Engine (which contains the PhysicalMaterial class) cannot depend on classes in the PhysXVehicles plugin.
    Where can I find PxVehicleDriveNW.h class to provide support for N-wheeled vehicles? There is no such class in plugin.

    Upd: looks like now I have to use PhysXPublic.h for this.
    Last edited by Kelheor; 02-09-2017 at 09:47 PM.

  36. #236
    0
    Is it me or is it not possible to have a Map with a Array-Value?
    I can't choose the Value Type as an Array

  37. #237
    0
    Quote Originally Posted by Raildex_ View Post
    Is it me or is it not possible to have a Map with a Array-Value?
    I can't choose the Value Type as an Array
    Try to put the array in a struct and then use a Map of those structs.

    In C++ you can have TMaps of TArrays, but in BP you also can't have TArrays of TArrays, so I would not expect TMaps of TArrays to be possible without using that extra struct.
    Easy to use UMG Mini Map on the UE4 Marketplace.
    Forum thread: https://forums.unrealengine.com/show...-Plug-and-Play

  38. #238
    0
    I know about issue UE-10109 and i just want to note
    There is laggish/freezing (few ms) process of "level streaming" in Preview 4 . Ive play with relative settings as well (garbage collection, background async) - doesn't helps.
    Ive tried to run packaged build - better but still few ms freezes. Sound is like blocking main game thread.

    And Im not sure but i saw issue in roadmap is DONE. Hm... Or not?

    Always checked on MacOS, UE 4.15Preview4. Never in windows.

  39. #239
    0
    Quote Originally Posted by JoeWintergreen View Post
    I just want to draw some more attention to this. A lot of us have been waiting on it since forever. Data tables are way less useful without it.
    Just Quoting you to again draw attention :P

    But yeah, i Agree, this would help soo much!

  40. #240
    0
    Promoter
    Join Date
    Dec 2015
    Posts
    188
    Quote Originally Posted by Raildex_ View Post
    Is it me or is it not possible to have a Map with a Array-Value?
    I can't choose the Value Type as an Array
    If I remember right, this isnt possible in C++ either. But I feel like I could be very wrong.

    nevertheless, if you wrap the TArray in a struct, you should be able to have it as a value.

    By the way: Is there a releas date for 4.15 already?
    Last edited by rYuxq; 02-10-2017 at 03:17 PM.

Page 6 of 7 FirstFirst ... 4567 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •