Download

Woot! Blender 2.71 has updated FBX!

not tried this but if you link/parent the objects together then export the scene , on import select skelmesh then in the advanced properties tick the rigidmesh option that might work , and tick the import animation box

Great news that the Pose is correct now and the extra bone is gone! But do the shape keys really not work anymore?! I need that function badly :frowning:

Well, the export doesnt work for my skel meshes. UE4 tells me something about multiple Root Bones ? wtf…

Edit: Managed it…

Is there a Way to not mess up the animation when i changing the hirachy of the Bones ?

to be honest thats a blender thing and not UE4, i’ve no idea how blender stores the anim info, so that sort of thing might be best asked on the blender forums.

sorry i can’t help more than that

I tried that and the animation was funky in the preview of it- it didn’t look like my mesh at all in the animation- very small and oddly shaped. But the model shows up to-scale when I dragged it into the level, so it wasn’t a scale issue. I’ll just export the door separately I guess. Thanks for the suggestion though!

Shapekeys don’t work only with 7.4 binary export. If you stick with ASCII export; Shapekeys and everything else works fine.

Mont29 has been working on shape key support for the binary exporter/importer. See the latest commits here: https://developer.blender.org/diffusion/BA/history/fbx_io_development/io_scene_fbx/export_fbx_bin.py;702f793d0f9d0fa5cced3425ff1e628c10595fc6
I guess any testing for UE is much welcomed :wink:

hey thanks for the link mAlkAv!An

Hi Guys,
Thanks for all your work in getting Blender and Unreal Engine in better sync with each other! This is great news for us that use Blender as our primary 3D package.

blender 2.71 is out now Download — blender.org

I think I have a fix for the “Armature|BoneName” problem: http://blenderartists.org/forum/showthread.php?343222-Blender-2-71-FBX-binary-exporter-bone-naming-problem&p=2687573&viewfull=1#post2687573

Hmm I’m getting this weird deformation on the arms, I just upgraded to blender 2.71 and I used FBX 7.4 Binary.

I have multiple characters using the same rig and when I export the animation/skeleton-rig for a character I make sure the armature is called ‘human’.

Should I be using 7.4 Binary or 6.1 ASCII? or have I missed a setting to get this problem? I am using MakeHuman -> Blender -> UE4.

Neurocase, I just tested and I’m not getting any issues. But I’ve only tested with both skeletal mesh from 2.71 and also animation from 2.71

Are you importing your newer skeletal meshes from 2.71 using your older animations(from previous Blender version) from within Unreal?
That might be causing you’re bone rotation issues.

Thanks SememeS, didn’t realize new **Blender **version was out, I’ll test the Blender 2.71 now.

Here’s workflows I’ve tested of Import/Export of **content **and their settings, Unreal Engine 4, Blender 2.70a, Hexagon, and Sketchup Make, for DAZ Studio 4.6 Pro should be same as for Hexagon, haven’t checked it yet but the stuff used to work for UDK so it should work for Unreal Engine 4 as well.

Content Import and Export Settings with Blender 2.70a in Mind:

The only problem I had was when going from **Unreal **to **Blender **to Substance Painter, vs **Unreal **to Substance Painter or **Blender **to Substance Painter, and getting the look to match when back inside Unreal Engine.

UPDATE:
Ok, tested Blender 2.71, works, no errors on my end, they improved the UV Mapping, shows proper aspect ratios proportions now on UV Map grid visually.

In other words, instead of looking like this:
311582d637509872119b88324a3957e60a9fb2c5.jpeg

It looks like this:
5e1d08fa51185ff4d66fb642ca6ce6754d7502a6.jpeg

Nightly build has updated version of the FBX exporter. Shapekey exports(with binary) are added!