Download

(WIP) map -Tagoria

hi fellow arkers,
Ive finally managed to have a working map…
I will keep daily update (more or less) of how it devolops.
Im starting with a 32/32 area that will be the first island (graslands)
idea= dunno yet…but very beautifull it must be.
took me 1 week to get the new foilage in, so new harvestable trees, bushes…
Today update:
Ive managed to make a working map with submaps, on the far and near i putted my stuff (took some tiime= no faster way??)
Ans started roughly sculpting what i wanted.

here first screenshot :slight_smile:

cooked it and tried it on steam…FAILED…
spawning somewhere under my landscape it seems…
any help?

help pls…

I like your field, looks nice.

Are you spawning above the landscape and falling through or actually spawning below the landscape?
The obvious question would be are all of your spawn points above the terrain.
If you can pinpoint where you are spawning find that point in the editor and see if you have a spawn point in that location.
Also check if the point is at 0,0,0. If so, you likely didn’t configure your spawn points or world settings correctly.

As for speeding things up, for vegetation try making one vegetation template that has all the correct settings and what you want, then you can copy that into the vegetation layers for your individual levels, that way you don’t have to go through and set up each foliage on each level. That would be a nightmare.

thx for the reply
love ure speeding upcopy :slight_smile:
the problem is that i spawn under my landscape (fixed by setting landscape on “block all” insted of ground or groundterrain

biggest problem is that my field (custom stuff from kitedemo) isnt cooking at all…
the hill trees i got working once, but thats it…
in devkit all is looking pretty…ingame it failes like a ****
ive mad sure everything is in the mod folder, but somehow its failing, dunno why
really want to add the kitedemo stuff from eu4 on it, its very nice…
and i made it all harvestable

here are my files: made a new one “dinotopia” with myy custom stuff in, if anyone would like to take a look why its not cooking pls tell

The KiteDemo was likely imported using a different version of the engine. Try checking the materials for your assets and making sure they have all the correct referenced assets as well as not using functions that don’t exist in the ARK kit.

im a noob at this…
how can i see the functions ark doesnt support?
and how to fix?
any tutorials on that?

try to recompile all materials. the material will throw errors if something doesn’t work. if a function is missing, there is nothing you can do, sry. but in general I would recommend finding the actual problem by method of elimination. take one item from the kite demo put it in a basic test mod/level and cook that one and test it. once that works add more and so on until you find the problem.

The function will show up in the blueprint as something like “unknown function” or something similiar. I think it also turns red.

oh yes, but i filles all those things in, like in the demo, but linked to the ones inside my map folder…didnt work
will try to do the eleimination process :frowning:

also question: i have friends who want to help making a map, but how do you do that??
can 2 people work on the landscape sublevel at once?

another problem is, (only vanilla stuff) is when i cook and play my map in steam…all is good
but when i want to make a change and cook/upload again…
it downloads the new mod on steam, then isntalls it…but then again downloading, installing,…it never ends…
do i have to enable or disable something for making changes and upload it again?

thx for the replies :slight_smile:

used the template from uzumi, tested it and worked…
then i added some more trees and foliage and cooked/uploaded again
it doesnt show
i hate this

fixed by veifiying mods folder in steam itself, it kept downloading, hope i wont have to do that everytime lol

next problem: now the new trees and bushes are there, but sometime the screen goes completely black/green or blue, depending where i look at, then if i turn around a bit its back to normal??
any ideas on that?
微信截图_20160917235534.png
微信截图_20160917235348.png

Saw on other threads that has to do with the ocean pre-processing being turned off or some such HELP - Screen turns black while testing game - Support - Unreal Engine Forums there is another comment a bit higher talking about the day/night cycle

uzumis says there:
This has to do with the main post process for your ocean, make sure its setup correctly and is located on your persistent level (main level) as it needs to be loaded everytime…

it is :slight_smile: but still that problem…

day/night is working (also from the template from azumi)

and underwater and dont have that problem, i ca 360 look around, only above water its bad

Well he also said “set up correctly” it may be on the persistant level, but is it on? right values? I don’t do mapping, I do scripting/blueprints, and working on mesh work now so I’m just trying to help any way I can, even if that means finding another thread that had an answer

yeah, in editor all is fine…but…rlly dont know