Windows 8.1 installer error 2503 and 2502


I already followed the suggestions posted in this other question:

But I’m still unable to install the Launcher. Here is the Log generated. I made sure to have full control in C:, Program Files, Program Files (x86), and the Windows\Installer folder. When I try to run the Launcher as Administrator by right-clicking on it, an error appears:

[Window Title]

This file does not have a program associated with it for performing this action. Please install a program or, if one is already installed, create an association in the Default Programs control panel.


I had to run it as Admin using the Run command. My date and time are correct and synchronized. I really have no idea what to try next.

Thanks for reading.

Hi J_Van,

Try the troubleshooting steps in the ‘Unable to Install the Launcher’ section in the link below. Please with us if you’ve already tried some of them from the report that you linked above. Post back and let us know your results.

Sorry to hear you are having trouble installing. This is an odd Windows Installer issue and not directly related to the Launcher installer. After looking at your log, I was able to pull out some of the error info that is being reported by Windows Installer and used it to do a few searches.

The key bits of info in your log are the following:

  • Note: 1: 2203 2: C:\WINDOWS\Installer\inprogressinstallinfo.ipi 3: -2147287035
  • DEBUG: Error 2503: Called RunScript when not marked in progress.
  • DEBUG: Error 2502: Called InstallFinalize when no install in progress.

Using those search terms, I was able to track down some links that might help:

Microsoft FixIt Utility

Windows Installer (Internal Error 2203)

Hello, and thank you so much for your answer.

However, that wasn’t able to solve the issue. I downloaded and ran the FixIt Utility from Microsoft. At one point, it asked me for the program I was trying to install (and having problems with). But the Epic Games Launcher didn’t appear on the list. When I chose the option “Not Listed”, it simply ended saying “No problems detected”. It didn’t actually fix anything.

I also followed all of the three methods of the second link you posted. None of them worked, unfortunately. The same error keeps appearing.

I’m stumped, as I can’t download the Unreal Engine now that I have a subscription for it. Is there anything else I can try?

I will look over your logs in more detail but in the mean time you can use the following internet search terms to find related issues/solutions.

Search for these:

  • Error 2203
  • C:\WINDOWS\Installer\inprogressinstallinfo.ipi 3: -2147287035
  • Error 2503: Called RunScript when not marked in progress.
  • Error 2502: Called InstallFinalize when no install in progress.

I searched with those terms you suggested and followed a suggestion from one of the results. Apparently running Windows Explorer as Administrator and running the installer again was able to fix the issue. The launcher is now installed and downloading Unreal Engine. Thank you so much for your help!