Why doesn't github have UnrealBuildTool.exe?

ok I did that and the bat file on admin and setup worked I did admin for the GenerateProjectFiles and sorry if I am annoying you :frowning:

(PS: with that .net thing are you talking about the C++ with UE4 or something else. I have the UE4 C++ but still have the error do you know how to fix the .net problem? )

I have searched it up for hours but never found the exact answer the exact error is C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\15.0\bin\Roslyn\Microsoft.CSharp.Core.targets(71,
5): error MSB6006: “csc.exe” exited with code -532462766. [C:\UE4\ok\Engine\Source\Programs\DotNETCommon\DotNETUtilitie

GenerateProjectFiles ERROR: UnrealBuildTool failed to compile.

I fixed it apparently the problem was that I needed to repair the visual studio Thank you for you time and effort if I stumble across any other error can I ask you? Stay cool man! I felt like I was being annoying but you still were there for me so Thank You!

why does the initial build for source take forever? It has already taken two days and it’s not even half way

I have stumbled for weeks on the dedicated server and I got frustrated when I didn’t have the configuration settings “Development Server” “Development Client” “Shipping Server” and so on. So I manually made new configuration settings but when ever I used them they gave me (literally)hundreds of errors about not able to find specific path. So I looked on different forums and found out that they solved it by switching the version to the source. I did that then gave me the error “Missing C:/Users/tjsun/Documents/Unreal Projects/Engine/Binaries/DotNET/UnrealBuildTool.exe after build”. I check the path it gave me to find out that there was no “UnrealBuildTool.exe” I checked the GitHub to get just the “UnrealBuildTool.exe” but I searched the file and it wasn’t there, but switching to 4.16 still works. Is there another way to get the configurations? If anyone could help me I would greatly appreciate it.

Compile it yourself? Thats why you have full Source :stuck_out_tongue_winking_eye:

Thank you very much for answering!!! but I do not have the Programs folder in my project

What are you using? Source or Launcher Version? And what are you trying to Build? Server Solutions are avaivable in Source.

There is already a big guide on how to Build a Dedicated Server on the Wiki you might want to look into.

That’s the thing I tried to switch to the source but it wont let me because I was missing the UnrealBuildTool.exe so right now launcher


That makes no Sense. You can Switch to source any time, it will update your Solution file and at that point you are on Source. Follow the Guide and you will be allright. Dont forget to Build your Engine Source and runt the Commands in the Source folder (also described in the guide aswell as on the git repo).

From the Screenshots you Posted I can Tell you did not Build the Engine at all.

Thank you and my GenerateProjectFiles.bat doesn’t work either it says csc.exe excited with code and by the way what is your profile picture

So why don´t you tell us this in the first place :stuck_out_tongue_winking_eye: my Profile Picture is a Chibi Version of Ichigo from the Anime Bleach.

The error basicly means you didn´t install whats needed on your Windows machine. if you google up csc.exe error you will see it has something todo with .NET make sure you have it correctly installed with VS or by Hand.

Also make sure you run Setup.bat and everything in general with Admin rights.

Here a Link how to Setup VS 2017 with UE4

wait what do you mean Us? You seemed like a cool dude so I searched Nachtmahr in google and showed a band are you them? Was I talking to a band? :open_mouth:

=/ rightclick .bat → Run as Administrator

And please stop skipping Steps! You have todo everything in order. If one fails for some reasson you don´t even have to bother trying the next step.

.net is a framework yours seems to be messed up or not correctly installed. I don´t know why you get the csc.exe error but there are many People out there that experience this and have different Solutions. You got to look it up on the internet and see what fixes it for you.


Unless you reffer to another error x) Im a little confused now.

You are using a Oudated Server Target file. Whatever guide you are following is Outdated :stuck_out_tongue_winking_eye: use the one from the wiki. The virtual function you try to override there does not exist and thats what the error is telling you.

Depends on your Rig. On my Rig it takes roughly 40minutes. A friend of mine has updated his Rig recently it takes around 20 minutes. On my couple years old Laptop it took around 90 minutes. Never heard of someone who needs to take more than a day =)

Congrats on getting the karma of the week list!