Download

VS 2019 - 16.3.1 version

I had this issue and I just reverted Visual Studio 2019 (https://docs.microsoft.com/en-us/vis…arlier-release) Worked for me…

I personally didn’t want to hack together a work around when broken math unit tests were coming into play. I have enough problems as it is.

Thanks, this worked!

For those who are fairly new to Visual Studio, here are the exact steps to enable that extra tool: Visual Studio > Tools > Get tools and features > Visual Studio Installer > Individual components (tab) > CHECK MSVC v142 - VS C+±x64/x86-Buildtools (v14.22) (This must be the specific version of 14.22, as there are a few).

You don’t actually need to do this anymore, the latest versions of VS 16.3 and 16.4 have fixed the compiler bug.

This worked for me when the issue first appeared but caused issues creating projects now in 4.24. Removing that file fixed the new issues.

*Update: After upgrading my engine version, I was again getting this error. The new fix:

Go to \AppData\Roaming\Unreal Engine\UnrealBuildTool>delete BuildConfiguration.xml>rmb the [project name].uproject file>generate visual studio project files

Also, just to be extra safe-I had read through this document: https://docs.unrealengine.com/en-US/…tup/index.html and noticed that the “Unreal Engine Installer” was not enabled. So, I went to VS>Tools>Get tools and features>“Installation details”(on the right-hand column)>Game development with C++>CHECK “Unreal Engine Installer”>Modify>Launch VS

I tried everything else in this thread and these two steps were exactly what I needed.

Deleting the old BuildConfiguration.xml is VERY important!