Download

Visual Studio 2013 Intellisense is REALLY slow

I’m highly doubtful Epic Games will switch IDEs. They are stuck for the same reason pretty much everyone else sticks to VS. It’s because the Console vendors write extensions for Visual Studio.

This doesn’t mean you can’t come up with your own solutions but have fun when its time to port to consoles

You can always at least edit in another IDE though. Shouldn’t be too bad. Only use VS for debugging

[edit] People posted good suggestions in the other thread similar to this one

I’m in the same position, none of the solutions suggested so far has worked for intellisense (the build times fix did work awesomely though).
I’m running an i5-3570K, 16GB of RAM and an SSD, so I’m pretty sure it’s not a hardware problem.

Also, sometimes it seems the whole setup gets confused, i.e. strange compile errors, and a simple restart of Visual Studio (without changing any code) fixes it.
I must say this is making it quite hard, especially being new to C++. In addition to considering my own questionable C++ skills, I must take Visual Studio’s feedback with a pinch of salt.

Intellisense usually kicks in after I’ve finished typing all the code that I want before compiling, and then squiggles start showing me errors which go away when compiling.

same here, the intelisense works when it wants and it is very slow.

Try going to Tools->Options->Text Editor->C/C+±>Advanced

Under the Intellisense tab set “Disable Auto Updating” to True.

This should help a bit (it stops the update of the intellisense whenever you change something which is why the thing is slow in the first place), however note that your intellisense might get out of date if you change bunch of stuff (usually it isn’t a problem)

How do you manually update, if you turn that off?

From MS website

I never encountered problems by disabling this option and it boosted the speed of the intellisense significantly (the first request is still very slow, all subsequent ones are instant on my pc).
If it starts creating problems you can always just re-enable the option, wait for it to update and then disable it again :stuck_out_tongue: (vanilla solutions ftw ^^ )!
I know that it has to update at least once when you open your project, but I’m not sure whats the criteria for subsequent updates, and I couldn’t find the answer for that either.

All in all, you should be good to leave it disabled. It still has to update whenever you start VS2013 and start your project so it won’t get out of date.

Make sure you disable any 3rd party plugins. sometimes 3rd party plugins cause this.

For example i used to have the same problem becuase i had CodeMap plugin enabled.

That being said, visual studio 2013 isa bit slow, but you should not be having the problems you are describing

interesting read on visual studio C++ performance : http://yosoygames.com.ar/wp/2013/12/microsoft-we-need-to-talk-about-visual-studio/

For me, I tried to disable auto-update and set max translation units to 10 and the intellisense seems a lot more responsive (I’ll happily let it take 1GB of RAM for the speed)

From Microsoft site:

Typically when IntelliSense is acting really slow I do a quick compile with a simple error and then everything starts to work rather quickly after that. It’s probably the fastest way then waiting for it.

int a = 15.0; // This pretty much does it since my compile times are around 2.6 seconds.

My major issue is that Intellisense spawns several “vcpkgsrv.exe” processes that are about 1 GB in size each. With 2 VS instances open, my 16 GB RAM gets eaten up in no time.

Wow this helped for me instantly. I can now finally use TAB to auto complete and the intellisense menu pops up instantly. VAST improvement. I’ll see how it goes before trying Visual Assist

Tossing a vote in here for VAX. It’s an excellent piece of software. Once you figure out how it works it’s even easier to use (e.g. if for some reason an entry is not in the autocomplete list, open the file that contains its declaration in VS and VAX will quickly parse it in - fixed!)

Tossing in my vote for Visual Assist as well. Using the 30 day trial now and cringing when it expires. Even started using it at work… works excellently - too bad i’m not a student though…

Ok at first I thought this was working well but was still having problems. I went and got Visual Assist and it works well, however error highlighting is still extremely slow from visual studio where it underlines in red. Is there a way to speed this up? I assume its part of the same problem

VAX is nice, but “Supported Microsoft IDEs* … *Express Editions not supported”.

Hmm, curious of upgrading to a solid state disk would help? Is this an issue of inefficiency with VS, then maybe I can overcome it with brute force. Been eyeing an SSD upgrade anyway for a number of reasons, and not that I’ve completely tossed the idea of getting VAX, if it’s all the same investment I’d rather put that into a new drive. Maybe by speeding up file and page file access this issue could be minimized.

Anyone running on a solid state drive having the same kind of intellisense issues? Maybe SSD users and loads of RAM are wondering why people are fussing over intellisense?

I’m luckily at UNI doing a post-grad so get access to microsoft dreamspark and all their products :slight_smile:

Yep. Same issues. I got everything on my SSD + 20GB Ram… just 5 minutes ago Visual Studio / Intellisense ran out of memory.

I bought VAX about one month ago. Its a huge improvement.

Ahh, nuts. Well, appreciate the confirmation.

Using SSD for both executables + code, and 16 GB RAM. Theory disproven. :wink: