Download

Very poor performance in the editor using multiple monitors

Just an update… I’ve given up working on more than one monitor for the past few days but this is still happening. Sometimes I’m getting 200ms for slate when I check stat gpu and I have to restart the editor which usually fixes it. Did anyone find anything out about this problem or are we just stuck with it? I tried posting in the answerhub but got no reply.

this is my life now…
(not even the worst case scenario)

btw I can’t use DX12 as proposed in the AnswerHub post because DX12 just crashes on startup


Fatal error: [File:E:\UE4\UnrealEngine\Engine\Source\Runtime\D3D12RHI\Private\D3D12Util.cpp] [Line: 242] (Device->*TPSOFunctionMap<TDesc>::GetCreatePipelineState())(Desc, IID_PPV_ARGS(&PSO)) failed at E:\UE4\UnrealEngine\Engine\Source\Runtime\D3D12RHI\Private\Windows\WindowsD3D12PipelineState.cpp:582 with error E_INVAL

Hey Chosker, that’s exactly what I’m seeing with slate. Just wondering which version of the engine and which build of windows 10 you have installed? also which gpu and which drivers?

I tried the direct x 12 thing but it made no difference, how do I know if it’s launched in dx12 or 11?

I’m on 4.18.1 but also happened on 4.18.0. I run on Win10.0.1506, and I have a GTX 970 with driver version 388.43 (was the same with the previous driver)

if you’ve launched UE4 with -DX12 in the command line (with a shortcut or a batch file) then you’re using UE4 with DX12, otherwise UE4 is running with DX11

I’m on 4.17.2 but I tried 4.18.2 and it’s exactly the same. I have windows 10 1709 and gtx 1080 driver version 388.59. I’ve even considered switching parts in my PC or upgrading my motherboard and CPU to try and fix it, hoping that it will make a difference somehow. Strange that my laptop that also has a 1080 and exact same version of everything works perfectly, it only loses a couple of fps when I open a new window.

Trying to work today using just one monitor. I have only the main editor window open but I still get the same slow down and can’t use the editor at all. Even restarting the editor doesn’t help.

I’ve noticed it always happens when a tooltip is visible, but also it can occur randomly and then won’t stop. It almost always happens when a window separate to the main one is open.

This is a very serious issue for me and has massively affected my work. I’m even considering changing to mac or win 7 to see if it fixes the problem. Can someone at Epic pleeease look at this bug. It sounds like I’m not the only one experiencing it and it actually renders the engine unusable.

tooltips can be a massive culprit of these slowdowns for me as well. when the editor runs fine it’s barely noticeable but when the slowdowns start then tooltips can be as bad as to half your already crappy editor framerate
for me usually restarting the editor improves it for a while, but it’s not long until the slowdowns appear again (usually less than 30 mins of normal work involving several editor windows)

I had same problems and the root of all evil was screen recording functionality from GeForce Experience. It tried to capture all windows UE4 Editor was creating and the more windows/tooltips I had the worse FPS I had.

Disabling that fixed all the problems with multiple windows for me.

I am running Windows 10 64bit - latest update (not sure the version number at this point)
3 24 inch Monitors all running HDMI out of a single card (1080 GTX)
No issues. I can run it across all 3, i can run it all on one, i can run it in any config and i have no change in performance.
All monitors are running 1920x1080
Latest Drivers for nVidia Experience
UE4.18.2

The issue seems to be that some are having the issue, and, most arn’t.
I would be curious to see what the root cause is, as, i think it has nothing to do with anything on Epics end.

Setup:

16 core AMD
64GB RAM
1080 GTX (EK Seahawk) @ 1920x1080
3x 24 inch monitors run from HDMI
UE4.18.2 installed to drive w/ 3TB free
Project running from 10k HD (non-SSD) w/ 2TB free
Windows running from M.2 SSD w/ 500GB free
Latest nvidia Drivers
no over-clocks on any device (cpu/gpu)
system running ~80 degrees under load, peak ~88 degrees.

HOLY SH*T

You are a genius!

I just uninstalled GeForce experience and the 3d vision drivers and BAAAAAM! Everything is back to ultra smooth!! :eek::eek::eek:

Now I feel stupid hahaha.

Anyone know a nice screen capture I can use instead?

edit: HAPPY NEW YEAR EVERYONE!! :cool:

Thankyou Zeorb, you dont have to uninstall it btw you can just disable it in settings

Geforce Experience is a freaking virus I swear! It kills performance on your entire PC. I never install it anymore. Try using OBS if you want a screen recorder https://obsproject.com and this is a screen of my settings for recording which seems to yield pretty smooth FPS in the 3D viewport:

Not as nice as FRAPS for 3D but useable. FRAPS can’t handle the multiple windows or the right click menus in the editor so OBS wins.

I know this thread is old, but I just figured out why my FPS decreased around 400% after an hour of work. I quit discord on my side monitor, and I’m back with 120 FPS!

You probably had it’s overlay enabled. I know that cause a lot of issues for games and 3d apps, so it wouldn’t surprise me if that’s what was causing your FPS drop.