Download

Vehicle physics problem

I’m following the unreal tutorial (Vehicles: Overview & Car Setup | 01 | v4.2 Tutorial Series | Unreal Engine - YouTube) wich can move the car without Wheel Blueprints and Animation blueprint (of course, I don’t expect rotation or movement from wheels, just movement from the car body)

Because the tutorial does it in that way

My mesh is kinda big, so I also lowered the mass scale of the mesh, but I still don’t get it working

As Jacky stated, in this image (above), you need to connect a wire from the “InputAxis Palante” node (green) axis value, plug it into the (green) throttle input on the Set Throttle Input node, otherwise your vehicle will not move! :slight_smile:

You have done this with the steering, but not the throttle. SEE BELOW:

&stc=1

Which part of the tutorial does that? :stuck_out_tongue: He is connecting the axis value to throttle, and thats what you should do.

Ops… that was a mistake, when i put the logs I deleted that connection, didn’t noticed when i did the screenshot, but connected still don’t works

And the same blueprint with the crash bandicoot kart works (with too much acceleration) so, I think is something from the mesh, I’m newbie on the 3dstudio, and I’m not confident about my skills
(here is the FBX, maybe u can see if someting is wrong http://www.mediafire.com/download/0nd36yf57uiz3ga/batBone0.FBX)

Thx for all the help :slight_smile:

Ok so I found the following issues:

  • All 4 of the wheel bones were rotated at -89.6 degrees on the Z axis, you correctly rotated the root bone, however after doing that you also needed to rotate the wheel bones, and then re-skin the car.

-Your vehicle was also centered on 0,0,0, which is a problem because the wheels (and half the car) are below the ground. For your vehicle,the Z axis value should always be greater than 0 if your pivot is centered to the vehicle (in this case it was 168.758)

-The wheel bones were not aligned to the center of each wheel, which would cause some crazy physics issues, each bone must be exactly in the middle of the wheel where the axle attaches to the wheel (in your case here, since the back wheels are 2 wheels each, you need to align that bone to the middle of the inside wheel, as this is where the pivot would be for it’s axle).

  • When you exported the model, you included 3 planes that were likely used as a blueprint while you were modeling the car, I have removed those, they were hidden, but may cause unwanted behavior.

  • I did this rather quickly, so there still may be some alignment issues, where a wheel may wobble a tiny bit (I did my best to center it, if it is not enough, open it in max and adjust it), but it should work as is, so give it a try!

Here is the model:

Hope it works for you! I have not tested in game, but it should be fine now. Also, make sure to open the file in 3dsMax as well so you can see what I did to make it work! :slight_smile:

It works! Thank you very very much!!

Now I need to adjust the size or weight of the mesh, cause is too big and moves so slowly, but I’m adjusting it and seems that is working well

THX :smiley:

Good to hear! To make it go faster, adjust the Torque Curve in the vehicle blueprint details panel, that will be the quickest way to add some acceleration. :slight_smile:

Thanks for the info!
Just one question: should i import the exported mesh as skeletal? Are there any tutorial to make vehicles without bones?

Yes, you’ll import the vehicle as a skeletal mesh. And this process doesnt mean the car doesnt have bones, the bones get created depending on the linkage hierarchy you set in Max so you can follow along Epic’s tutorial and be just fine.

Here is what I did, and it works.
(Blender v2.74, Unreal Engine v4.7.6)
Blender:
Scene->Units->change to Metric and Degrees, Scale 0.01, and make sure the scale of car body and every wheel is one, if not, press control + a to apply.
The origin of the car body is 0,0,0 and every wheel is in each one’s center.
The car body and wheel must all above ground.
The front of your car is +X axis, left is +Y axis, above is +Z axis.
No need to add any armature or bones.
Don’t apply the car’s wheel its location(remain the value correspond to 0,0,0)
When export to unreal, make sure change Version to fbx6.1 ASCII, or the car will be very big in unreal engine, others remain default.
Every car wheel’s parent is car body.
The vertices of car body doesn’t include car wheels, just their parent.
Unreal Engine:
Import the car as skeleton.
Create a vehicle pawn blueprint, and select your car mesh.
The wheel bone name is the name in blender, for me, I type Tire_frontleft in Element0, Tire_frontright in Element1, Tire_rearleft in Element2, Tire_rearright in Element3. Though the document of UE said the order doesn’t matter, I didn’t try.
Next set the pawn class throttle input and steering.
Change the physic asset all four wheel to kinetic, and car body to box or simple convex.
Down to here you should be able to drive your car. And remember to set your game mode default pawn class to your car’s pawn blueprints.

I swap the fbx model in unreal engine tutorial, and it works well.

Where can I find that my wheels are going though the floor please reply I been trying to do this for 9 days and I feel like I wanna ouch my PC

“Punch”. I mean to say

If the wheels of the vehicle are intersecting with the ground you probably need to increase wheel radius in your wheel BP’s.

WOW!!! This thread in going the distance :slight_smile: Great job!

I have a few vehicles in my game and one issue that I have been tackling on and off for awhile now is the wheel collision. Not the collision with the ground but the side collision. If you put a box around the car and wheels it will collide and keep the wheels from going into the ground if the car flips on its side, but the problem is when you try and jump off a ramp at high speed the collision box hits the ramp and stop the car and that is no fun :slight_smile:

The best way or most realistic way would seem to have the tires and vehicle have “Single Convex Hull” but the problem is like was stated in this thread that the wheels collision does not work so if you run into a wall or flip on the side the wheels go all of the way through the walls or floor.

I have played with different boxes to block parts of the wheels while trying to leave enough wheel so the box would not hit things easy and bottom out the car. It is possible to have actual collision around the wheels in the newest version of Unreal?

Hang on!!! I was taking some screenshots of the tires going into objects. I started with the yellow ramp and then I just happened to think of making a screen shot of the tire going through a white box, but to my amazement the tire pushed the white box out of the way :0 WHAT IS HAPPENING HERE, did 4.19 change the wheels to have collision all the way around or???

The plot thickens!! If you turn off Physics for the boxes the wheels collision does not work. Is there a way to make the wheels collision, collide with static objects also???

Hey,
Scienziatogm ,
Can you give me some pointers on how you made the kart?
i made one myself but the textures doesn’t look so good
(on the colors it all stretches out when i put an other material on it.),
and even the shape isn’t so great compared to yours.

Do you have a solution for this problem with static objects? I have this problem when I set the “Physics Type” to “kinematic” in my Physics Asset. But I must set it to kinematic, because I have a forklift and the forks must be moveable. This was the only way to collide with objects where are the Physics enabled AND move these parts.