Unreal Engine 4.20 Released!

I saw that mentioned a while ago in the commits, they were getting more include paths than some compilers could handle and decided to cut everything off at the Public folders to fix it

The problem is that if you place the engine source in a really deep path (C:\Development\GameEngines\UnrealEngine4\Latest\Engine…) then when compiler tries to compile source code, UBT will add all the include paths to a .response file used as input by the compiler. The max .response file for Windows (when compiling with symbol information) is 64K. Having the really long explicit path to all include folders in the .response file can easily cause it to exceed 64K in size. Having a shallow path (C:\UE4\Engine…) will prevent this, but not everyone has things set up that way. So now, instead of adding all sub-folders for a module/plugin to the .response file as an include path, UBT only adds “Classes” and “Public” folders and you have to modify the #include statement to specify the rest of the path to your .h file.

Ok, I am crazy or Niagara makes some basic stuff super time consuming? To create a simple particle with 3 emitter you need:

• Create a Niagara System
• Create 3 Niagara Emitters
• Add the 3 Niagara Emitters inside the Niagara System

And if I need to add 1 more Emitter I need create another emitter outside the Niagara System and Add it to the the System.

Add a way to create Emitter inside the Niagara System that go inside the Niagara System folder. Them you create a Niagara System and add 3 emitters inside the system.

In trying to step up to 4.20 from 4.19 we discovered that we can no longer use our custom online subsystem plugin due to changes made in how FUniqueNetIdRepl is serialized with the new encoding scheme.

When trying to connect client and server we are getting an “Error with encoded type hash” message. Digging into this we found a change in the FUniqueNetIdRepl::NetSerialize method that now uses new methods on the online subsystem utils class to convert a hash value to a subsystem FName however there is no way currently to inject a new subsystem to hash mapping for custom plugins.

Is this intended behavior, an oversight or are we missing something with how to add a new custom online subsystem plugin since the 4.20 change?



I’m game designer of a project made with the asset “Paragon: Minions” and it isn’t compatible with 4.20. The heroes assets are compatible, but we never planned to use them.

Would you recommend us to wait for a compatibility patch or stick with 4.19.2?

We just finished the presentation and send it to the Unreal Dev Grant, it’s a big issue for us! As you can see, we worked really hard the last 2 months and we had almost finished a prototype for Kickstarter:


What is wrong if new Feature on Opegl ES 3.1 , Hardware Occlusion? it seems it will hide quite easily everything a bit far from center of camera view, can we somehow control this? (Snapdragon 820) , Android Oreo .

EDIT : i will add that it seems that it occludes meshes based on their screen size, which its quite obvious when pitching up/down the camera while centered on the object…

it requires something to change so it behaves like pc ( or near as pc) or it is just bugged?

Seeing the same thing on my side.

Anyone have a workaround or fix for this?

After upgrading my projects from 4.19 to 4.20 the tick event has stopped working completely on all of my UMG widgets that have a C++ parent class, which is pretty much all of them. I made a quick test widget without a C++ parent class and the tick event worked fine in it. I tried playing with the new “Tick Frequency” setting on the widgets and got nothing. I tried deleting and re-adding the tick event and got nothing. I tried overriding the tick event in C++ and threw in a debug print on it and got nothing from the native tick either. Ive done the old delete the intermediate folder, rebuild, blah blah. Other things in the widgets like construct event, button clicks, etc work fine. Anyone else having this problem?

Ok so I made a c++ test UserWidget class to use as the parent for the test widget I made. As soon as the parent class is changed and the project recompiled the tick event stops firing. I guess its time to dig through engine code…I suspect it has to do with the new “Tick Frequency” setting. I posted as a bug report on answer hub.

Has anyone been able to package a Win32 plugin? I can’t get a blank Runtime blueprint function library to successfully package. The only warning I get has something to do with and there are no errors, but no binaries are generated.

UATHelper: Package Plugin Task (Windows): Running: C:\Program Files\Epic Games\UE_4.20\Engine\Binaries\DotNET\UnrealBuildTool.exe UE4Game Win32 Development -plugin=C:\Users\ABCUSER\Desktop\DoublePlugin\DoublePluginBuild	est420plugin\HostProject\Plugins	est420plugin	est420plugin.uplugin -iwyu -precompile -nosharedpch -noubtmakefiles -receipt=C:\Users\ABCUSER\Desktop\DoublePlugin\DoublePluginBuild	est420plugin\HostProject\Plugins	est420plugin\Binaries\Win32\ -NoHotReload -ignorejunk -log="C:\Program Files\Epic Games\UE_4.20\Engine\Programs\AutomationTool\Saved\Logs\UBT-UE4Game-Win32-Development.txt"
UATHelper: Package Plugin Task (Windows):   Using Visual Studio 2017 14.14.26428 toolchain (C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.14.26428) and Windows 10.0.16299.0 SDK (C:\Program Files (x86)\Windows Kits\10).
UATHelper: Package Plugin Task (Windows):   C:\Program Files\Epic Games\UE_4.20\Engine\Source\ThirdParty\Expat\Expat.Build.cs: warning: Referenced directory 'C:\Program Files\Epic Games\UE_4.20\Engine\Source\ThirdParty\Expat\expat-2.2.0\Win32\VS2015\Release' does not exist.
UATHelper: Package Plugin Task (Windows):   Parsing headers for UE4Game
UATHelper: Package Plugin Task (Windows):     Running UnrealHeaderTool UE4Game "C:\Program Files\Epic Games\UE_4.20\Engine\Intermediate\Build\Win32\UE4\Development\UE4Game.uhtmanifest" -LogCmds="loginit warning, logexit warning, logdatabase error" -Unattended -WarningsAsErrors -installed
UATHelper: Package Plugin Task (Windows):   Reflection code generated for UE4Game in 9.2018734 seconds

Hmm, on updating this Blueprint-only project to 4.20 from 4.19, I crash when trying to play my Persistent Level with this:

[2018.07.21-04.54.53:589][477]PIE: New page: PIE session: SGR_Persistent_001 (22 Jul 2018 12:54:53 am)
[2018.07.21-04.54.53:589][477]LogPlayLevel: Creating play world package: /Game/UEDPIE_0_SGR_Persistent_001
[2018.07.21-04.54.53:685][477]LogPlayLevel: PIE: StaticDuplicateObject took: (0.095888s)
[2018.07.21-04.54.53:686][477]LogAIModule: Creating AISystem for world SGR_Persistent_001
[2018.07.21-04.54.53:688][477]LogPlayLevel: PIE: World Init took: (0.003628s)
[2018.07.21-04.54.53:689][477]LogPlayLevel: PIE: Created PIE world by copying editor world from /Game/SGR_Persistent_001.SGR_Persistent_001 to /Game/UEDPIE_0_SGR_Persistent_001.SGR_Persistent_001 (0.099852s)
[2018.07.21-04.54.53:755][477]LogInit: XAudio2 using 'Speakers (Realtek High Definition Audio)' : 2 channels at 48 kHz using 32 bits per sample (channel mask 0x3)
[2018.07.21-04.54.53:780][477]LogInit: FAudioDevice initialized.
[2018.07.21-04.54.53:830][477]LogLoad: Game class is 'InFluxGameMode_C'
[2018.07.21-04.54.54:561][477]LogWindows: Windows GetLastError: The operation completed successfully. (0)
[2018.07.21-04.54.57:859][477]LogWindows: Error: === Critical error: ===
[2018.07.21-04.54.57:859][477]LogWindows: Error: 
[2018.07.21-04.54.57:859][477]LogWindows: Error: Fatal error: [File:D:\Build\++UE4\Sync\Engine\Source\Runtime\RenderCore\Private\RenderResource.cpp] [Line: 128] 
[2018.07.21-04.54.57:859][477]LogWindows: Error: **A FRenderResource was deleted without being released first!**

Smaller levels work, and this project doesn’t do anything with render targets, which is all I get on googling this error.

Cant compile my player BP at all, just takes ten minutes then crashes, in 4.18 compiled in like two seconds… And where is min roughness for lights? They all look really horrible now and that specular thing doesn’t seem to do much… In other words, when will there be a fix for this cause now I’m stuck not being able to do anything. Made a NOOB mistake and didn’t open copy, can’t downgrade cause it crashes. Also how do you adjust glossies/roughness of lights in new version?

and the only reason I upgraded was for dynamic resolutionwhich you failed to mention isn’t available for Windows, which makes no sense at all, surely that would the first thing you do if your implementing that feature? Next time lead with the fact it’s not on Windows cause you got me good!

Also, just out of curiosity, if this be all end all feature known as Dynamic Resolution that massively increases the framerate of our games that you hooked us all with actually exists, then how the hell are you supposed to test it? cause we’re pretty much all on windows machines… are you telling me you’ve gotta package a build for xbox or playstation every single time you wanna test it? seems counter intuitive that you would develop features for any platform other than windows first! everything else afterwards… imho…

seriously Epic! your logic is flawed! we are all on windows machines, except for a few die hards on linux! how the hell are we supposed to test features for other platforms if it’s not a feature for the windows platform? in future, cause i’m really really annoyed now, please state the fact that THIS FEATURE IS NOT CURRENTLY SUPPORTED ON WINDOWS! at the very top of the new features description, cause you’ve really slowed me down… can’t do anything until you release a fix for this…

i mean cmon ffs! how stupid is that logic? we are releasing features you can’t actually test! we are developing features in a windows environment for a games engine that is mostly windows specific, and the features we are developing can’t even be tested on a windows machine… ugh what? duh…

do you know what i’d like to see from you epic! one stable build that isn’t a buggy mess that does what you originally said it was gonna do… does anyone remember the unreal engine 4 launch? “IT JUST WORKS!” yeah right… when has it ever just worked? every single update you release breaks everyones games and it’s almost like we’ve got to start over from scratch every single time because of some new promised feature, that doesn’t even work properly… give me a break… maybe i should get into games engine development… i mean how long has that delete folder bug been in the engine for? since the year dot…i mean epic? cmon? delete folder? is that complicated to do or something? is it really complicated to delete folders? so sick of all these games programs made by big companies, that release constant updates and don’t fix bugs that have been in their programs since forever, like the zbrush infinite cutting handle loop… or the 3ds max dissappearing menus… or the photoshop dissappearing features… it’s just really starting to wreckmyhead…

it’s actually really fing funny when you think about it, we’re dealing with a generation of wannabes that have zero skill when it comes to programming! they got their bachelors degree in college and then they get a job in a games company… and next thing every single game that comes out is buggy as hell on release, then after months and months and months it still isn’t even fixed… what surprises me the most is that people actually give these idiots money… no accounting for pure stupidity… i mean look at batman arkham knight, made with epics engine, the lead programmer on that was some kind of brain damaged idiot… how the hell are these guys making so much money?

look at squeenix, ten years for ffV, ten fing years! for a game that’s basically hold circle to win… wtactualF!!! i’m actually dreading ff7 remake, those are my precious childhood memories you ********! leave them alone!

as i said, no accounting for stupidity… people bitched and whinged about ninja theory’s DmC, because of the colour of a computer models hair? WTF? ugh…no offence losers… but ninja theory’s DmC game is probably the best game ever made so far… sorry your too obsessed with somebodys hair colour to play one of the best games in existence…polished to perfection… i actually went back and played dmc 4 se and i was like… ****… i can’t believe we’re getting another crapcom made dmc… oh noes… it’s gonna be corny and boring, with totatlly unrealistic characters… and if you watch the trailer you’ll just laugh your *** off at how bad it looks… thanks a lot whiners… we’re not even getting a sequel to one of the best games ever made because your obsessed with another man’s hair colour…

//End Rant

So whats going on with the plug ins? I have a bunch of meshes to paint in substance to start building a level. hopefully we have a full non beta release soon so all my ue4 goodies are good to go.

Had the same problem (I think).Its probably the way you create the Blutility in the first place. Coincidentally, there’s a nice video explaining it here:

Thanks yeah I just found the video… didn’t know there was an alternate way to create blutilities, I always just created them like a normal blueprint.

I had the same problem. Something to add in the documentation.

Widget: Get brush is now read only, my set struct members can’t work now, it was very useful since I could change multiple properties quickly.

Mobile Hardware Occlusion isn’t supported by Non-HDR mode? can an EPIC stuff answer this? is there any workaround on using LDR? thanks!

Any issues with a blueprint only project? Planning to upgrade from 4.18 to 4.20

When launching 4.20 for the first time the prerequisites stage made my system reboot (or at least tried to). If I need to reboot for the prerequisites install it’s fine but it would be nice to get a confirmation or anything (reboot now? etc). Just blindly restarting the system isn’t anything I’ve seen in other software.