Download

Unreal Engine 4.20 Released!

Yes, the fix for a curve atlas inside a material function crashing missed the 4.20 release, but it will be in the first hotfix. In the meantime, curve atlas row parameters should work in all cases except nested in a function.

Thanks!

Can you confirm that as of 4.20 you need High Sierra 10.13.5 minimum to run it on OSX?

I’m getting a major problem trying to work with a 4.20 source build. Every time I add a new file to the project, regen, and build, it dies on trying to build UHT:

Current workaround is to right click -> rebuild UHT every time this happens. Still very annoying.

LightmassCoordinator looks to be missing, plus the version of Lightmass shipped gives the same version number as with UE 4.19.

Passing arrays from server to client through multicast events does not work in 4.20. I’ve submitted a bug report.

Hello,

Thank you for reporting this issue. If you are able to reproduce this, please visit the link below for more details and report the issue using the new Bug Submission Form. Providing as much information as you can will help expedite the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks

Thanks Matthew, but that’s a little different to what I was referring to. In my plugin code, I now need to specify, as an example:


#include "Widgets/Text/TextBlock.h"

when previously the following would have sufficed (due to having “Slate” in my module’s PublicDependencyModuleNames list):


#include "TextBlock.h"

This extends beyond engine dependencies, to cross plugin dependencies and even intra-plugin module dependencies. I have to specify the full relative path (from “Public/”) when including a header from MyPluginModuleA into a file in MyPluginModuleB. It’s no big deal, I actually think it’s better this way. I was just checking whether this change was intended for plugins, since it has not been forced on game project code.

This doesn’t seem to be intended but I’m not 100% sure. As this could be a bug, can you please submit this, including all of the information you have on the topic, to our Bug Submission support channel? You can find the form here: https://epicsupport.force.com/unrealengine/s/

We’ll look into this further once you’ve done so.

Hello,

Thank you for reporting this issue. We are unable to reproduce this issue at this time and it shouldn’t be a problem as UBT isn’t case-sensitive. If you do have any further information to provide that could assist in reproducing this, please report this issue using our Bug Submission Form.

Hello,

If you are able to reproduce this issue, please submit a bug report for this issue through our new Bug Submission Form. Please visit the link below for more details.

https://epicsupport.force.com/unrealengine/s/

Thanks

We have a big open landscape scene, with trees, grass and that is the results of alot of transparency, which the translucency support for instanced stereo rendering had no impact on. Same drawcalls, same fps, same cost on the scene as before activation.

New: Translucency Support for Instanced Stereo Rendering
We’ve taken the improvements to the Instance Stereo Rendering (ISR) path that we made for Robo Recall, and improved them to work across more features in the engine. Unreal Engine 4.20 adds support for performing the translucency rendering pass using Instanced Stereo Rendering, which can significantly reduce CPU cost on translucency-heavy scenes. No content changes are needed; any project with Instanced Stereo enabled in the project settings will automatically get the benefits of Instanced Stereo Rendering.

Planting millions of foliages 4.18 takes 30min in 4.20 5sek what have you guys done :smiley:

Blutility mentioned in the first post, is this new system with old name or is it extension of existing blutilities?

I see absolutely no fixes on the issues that Code plugins had on compiling…
We discussed this a lot and showed examples but we had absolutely no answers from Epic

Has anybody been able to compile a plugin for 4.20?
I just finished updating a plugin and tried to rocket build it but it fails with the following errors (this has to do with the bug on Preview3 it seems):

C:\Users\DarkK\Documents\Unreal Projects\paperzd_builds\4_20\HostProject\Plugins\PaperZD\Source\PaperZD\PaperZD.Build.cs: warning: Referenced directory ‘C:\Program Files\Epic Games\UE_4.20\Engine\Source\PaperZD\Public’ does not exist.
C:\Users\DarkK\Documents\Unreal Projects\paperzd_builds\4_20\HostProject\Plugins\PaperZD\Source\PaperZD\PaperZD.Build.cs: warning: Referenced directory ‘C:\Program Files\Epic Games\UE_4.20\Engine\Source\PaperZD\Public\AnimNodes’ does not exist.
C:\Users\DarkK\Documents\Unreal Projects\paperzd_builds\4_20\HostProject\Plugins\PaperZD\Source\PaperZD\PaperZD.Build.cs: warning: Referenced directory ‘C:\Program Files\Epic Games\UE_4.20\Engine\Source\PaperZD\Public\Notifies’ does not exist.
C:\Users\DarkK\Documents\Unreal Projects\paperzd_builds\4_20\HostProject\Plugins\PaperZD\Source\PaperZDEditor\PaperZDEditor.Build.cs: warning: Referenced directory ‘C:\Program Files\Epic Games\UE_4.20\Engine\Source\PaperZDEditor\Public’ does not exist.
Parsing headers for UE4Editor
Running UnrealHeaderTool UE4Editor “C:\Program Files\Epic Games\UE_4.20\Engine\Intermediate\Build\Win64\UE4Editor\Development\UE4Editor.uhtmanifest” -LogCmds=“loginit warning, logexit warning, logdatabase error” -Unattended -WarningsAsErrors -installed
Reflection code generated for UE4Editor in 11.1038306 seconds
ERROR: The first include statement in source file ‘C:\Users\DarkK\Documents\Unreal Projects\paperzd_builds\4_20\HostProject\Plugins\PaperZD\Source\PaperZD\Private\AnimNodes\PaperZDAnimNode.cpp’ is trying to include the file ‘PaperZDAnimNode.h’ as the precompiled header, but that file could not be located in any of the module’s include search paths.
(see C:\Program Files\Epic Games\UE_4.20\Engine\Programs\Aut

The bug is the same from Preview3 (which fails compiling because it searches the private and public includes on the engine source folder, instead of the plugin one…

Without this changes we will not be able to compile any code plugin from the time being

  1. In Build.cs fully remove ‘PaperZDEditor\Public’ from PublicIncludePaths(…).
  2. (It could be a bug - read the messages above) Add to PublicIncludePaths all path to in-engine headers used in your plugin.

For example, build.cs in my plugin:

4.19

4.20

Thanks a lot @YuriNK will test it right away.

My Launcher isn’t showing 4.20 after install. Still says 4.17, 4.19. Mac OSX. Tried reinstalling, tried restarting. Ideas?

Hi all,

This is my first post here and I am a total n00b to UE4.

However, I noticed a change that impacted the projectile’s behaviour. It seems they are no longer able to bounce at all.

Can anyone else check please? It is a real pain because I am actually working on a bouncing ball game :stuck_out_tongue:

Thanks for your help guys, cheers.

Just tested it… effectively it seems i know have to add the public include path of all the modules i already added…
This will be a long afternoon

[USER=“36033”]Matthew J[/USER] when trying to use the Path.Combine… i get this error

c:\Users\DarkK\Documents\Unreal Projects\paperzd_builds\4_20\HostProject\Plugins\PaperZD\Source\PaperZDEditor\PaperZDEditor.Build.cs(12,17) : error CS0103: The name ‘Path’ does not exist in the current context

adding it as follows:
PublicIncludePaths.AddRange(
new string] {
Path.Combine(ModuleDirectory, “Public”)
//“PaperZDEditor/Public”, => changed
// … add public include paths required here …
}

By removing the include, i can further compile, but need to start adding PublicIncludePaths as YuriNK told me to.
Is this intended?

I can’t launch 4.20 for some reason. It’s giving me an error and soon after my computer attemps to shut down/restart. :confused: