Download

Unreal Engine 4.12 Preview

I am getting this error when I try to build on Android Platform.

“The binaries for this target platform are not currently installed, would you like to use the launcher to download them? unreal 4.12”

How do I fix this? I have my Android SDK located in the right place and the SDK in Project settings point to the correct folders.

But I don’t receive this error message in any other build in 4.10 and 4.11 Android Packaging works.

Also where in GitHub do I download the Vulkan Tools for Unreal 4.12? Thanks in Advance

You’ll need to add the Editor Symbols for Debugging to your download of the editor otherwise you won’t be able to build for these platforms.

You can add this after the fact by going to the launcher and down-arrow on the Engine launch button in the Library. Select Options and add the “Editor Symbols for debugging”. Once this downloads you’ll be able to build for your specific platforms.

This workflow will be improved soon.

Sure you have to render twice, but that’s the same with box, spherical, and screen-space reflections and yet they all work in VR too!

I’m probably beating a dead horse, and if this post gets ignored so be it, but planar reflections are something I’ve been looking forward to for a long while. I can indeed get under frame with using them in VR, unless the way they are now (lagging behind the rest of the scene) is the reason that they are rendering with a lower .gpu cost (in which case the rest of this post is kind of redundant).

I did some tests as the planar reflections are now in Preview 5, if there looks to be a problem with my methodology please let me know! My test scene has 3 dynamic shadow casting lights, all the primitives you can see, and two Vive controllers which both total about 30,000 triangles. Screenshots and profiling was done within the HTC Vive with a screen percentage of 140%. On the left I tried to emulate accurate reflections (reflection of environment with a box refl capture and reflection of local objects with SSR) In the middle, no reflections. On the right, only planar reflections at 40% screen space.

SSR+Box: 7.20
No reflections: 5.94
Planar: 7.53

In conclusion, planar reflections are the most expensive, but they’re the only thing that actually comes close to emulating realistic reflections on a flat surface (and they look amazing). Unless I’m missing something, planar reflections not being performant in VR isn’t a good reason for their lack of VR compatibility. I only GPU profiled, I don’t know how the CPU compares but I imagine it increases drawcalls with planar reflections too.

http://i.imgur.com/ebnIF5At.jpg http://i.imgur.com/WvC1ze8t.jpg http://i.imgur.com/786hU09t.jpg

Hey, OSVR Plugin now works well in 4.12 Preview 5. Thanks Unreal team.:):slight_smile:

Thanks that did the trick! How do I add the Vulkan API from GitHub? Where is the repo?

Right, it’s available through GitHub. The wiki linked below should help you get setup and started.

Guys, where are the .cpp files for engine source in 4.12? I can’t search for them in Visual Studio now - none of the engine .cpp’s are there :confused:

Please please don’t tell me I need to download source engine for this now… I have installed the debugging symbols.

I upgraded from 4.12p3 to p5 yesterday and still have all of the source available. Did you just install preview 5 (fresh copy, not upgraded from previous preview)?

I did notice the download was only ~3gb for the preview 5 upgrade, if you installed from scratch was it the same size?

This is probably some error on my part and has nothing to do with the engine version but I’m getting crashes when calling Destroy on actors in 4.12. I can’t recall having this issue with previous versions. I do the destroy call in a collision overlap callback.

It crashes in the engine updating overlaps of child components. Although I would have expected Tick wouldn’t be called after the object is destroyed. If I manually add a new method to defer a Destroy call then it seems to fix the issue. Of course that’s already what I expect Destroy to be doing.

I put more detail here :

https://answers.unrealengine.com/questions/425611/crash-when-destroying-actor-in-overlap-callback.html

Nah I had p4 installed beforehand, but I did just format this machine. Having to search on GitHub at the moment rather than using VAX, it’s horrible :frowning:

So just now I opened the Epic Launcher and saw that preview version 5 was available now. I updated my engine and rebuilt now everything works with the same code. I guess there must have been a bug in 4.12.

Is there any update on UE-30063? [MENTION=4894]Tim Hobson[/MENTION]
Here’s the answerhub link to the issue:
https://answers.unrealengine.com/questions/393761/411p8-bugeditor-freezes-while-compiling-character.html
Thanks!

+1 here too.

I upgraded to 4.12 r5 from r4 and I believe that must of been when the .cpp files went missing. I verified and it solved nothing, so I uninstalled it and deleted everything and reinstalled, after which they came back. Last night I formatted my computer and put windows 10 back on but barely anything at all is on my OS drive, so I reopened the launcher and hit install and it reinstalled it with the files already present, then the .cpp were missing again. So I did the same as before but now they wont come back no matter what.

The only thing I haven’t done while trying to get them back which I’m trying now is to uninstall -> delete all files -> reinstall instead of uninstall -> reinstall, I don’t recall if that’s what solved it the first time around. I will update when I know.

Edit: .cpp files are missing from launcher 4.12 r5 and I can’t find out how to get them back - reinstalling doesn’t work even while deleting the engine folder etc after uninstalling.

AttachTo is in 4.12 r5 Deprecated

What can i use in exchange AttachTo?

SetupAttachment if you’re it’s in the constructor. Otherwise just look at the header, it might even tell you in that warning line IIRC. Other primary one is AttachToComponent IIRC. I don’t have VS open atm.

What is UE-30842?

I would really like planar reflections available in VR… just for the fact that we as developers could be smart enough for when and where to use them… bathroom mirror with no real envrionment to render… etc…

Use AttachToComponent(). The build log does tell you what to use when a function is deprecated. You do have to provide arguments now though.

Currently that one is marked for a fix in 4.13. Keep in mind that no fix has yet to be submitted so this fix version is not a gurantee and can be pushed to a later version.

Here is the AnswerHub link for context: Flickering dynamic shadows on translucent surfaces - UE4 AnswerHub