UMG video don't work on device

Hey i’m having trouble playing a intro video on my device (IOS) it won’t play or show up, i try different format, different sizes but noting any suggestion ?

Hello Juanjose09,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. What version of the engine are you using?
  2. Can you reproduce this issue in a clean project?
  3. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  4. Could you provide screen shots of any blueprints/widgets that may be involved in this issue?

I’m using 4.10, i also tried using 4.11 clean project on both but no luck.

Thank you for the additional information. However, I am a little unclear as to what you meant when you said “no luck”. I have a few more questions for you.

Additional questions:

  1. Did you mean that you were not able to reproduce this issue in a clean project or that the video did not play in a clean project?
  2. What device exactly are you using?
  3. What is the current OS that is being run on the device?
  4. If you cannot reproduce this issue in a clean project, could you provide the project that is experiencing this issue?
  5. If you provide a project, could you provide the steps needed to reproduce this issue in that project?

No luck as of don’t work, i’m testing on two iphone 6 running on 9.3 and the other one 9.2.1 i also try adding the video mat to a box (BSP) but when packaging and testing it on the device it appear with a different texture not the video mat…weird, look like a bug or i’m just doing something wrong.

can you give me your private email so i can send you my project ?

Hello Juanjose09,

If you would like to provide your project, you could do so by sending in to me in a private message on the forums via dropbox or google drive.

Hello Juanjose09,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

Apparently i was using the wrong video format, the only video format that i can play in unreal is WMV however when i imported a MP4 video in unreal it doesn’t play it only give me a black screen but when a package my game for my iphone the video work i guess this is a bug.

Hello Juanjose09,

With the new information that you have gathered, are you able to reproduce this issue in a clean project? If so, could you provide a detailed set of steps to reproduce this issue on our end?

Hey sorry for the late reply i upgrade my engine to 4.12 but i still have the issue i tried a different video, same format (MP4) but doesn’t play in the editor, i uploaded the video through explorer and through the engine itself but don’t work, WMV is the only video format i can play in unreal.

I now package my game and now not even mp4 video won’t play, i got everything setup just like your document but nothing work ?

Hello Juanjose09

I have a couple of links to documentation I would like you to look over. Both of those should get you going in the right direction. Make sure to place your media asset file within the Content/Movies folder for it to play correctly in a packaged project. I hope that this information helps.

Make it a great day

If your MP4 file includes audio codec that is not accepted by your device or player you can use a professional MP4 video converter - iDealshare VideoGo to convert your MP4 file to your device or player supported one with supported audio codec. How to Solve 'MP4 Plays but No Sound' Issue?