UE4 Stalls on Updating Engine


This question has been mentioned before in these threads and I’ve tried some of solutions in this answer hub to no avail. We are trying to install UE4 for my school for next year to be used on 13 machines. When trying to update the UE4 engine, it stalls on a Please Wait message. Tried altering defaultengine.ini files. Here is the log file for you to look at. Any suggestions. We are trying to download with a proxy.link text

Hi Collingwood College.

Being behind a proxy can definitely cause this issue. You will need to add an exception for the Unreal Engine. Your IT Dept should be able to do this for you.

Once this is done, if you are still experiencing the issue please let us know and we can continue troubleshooting.



I am part of the IT department here. Should the proxy exception be .epicgames.com or epicgames.com?

I’ve tried both of those and it still stalls on Updating unreal engine launcher - checking for update and please wait.

Hi Collingwood,
Try download.epicgames.com and see if that fixes your issue.

-Max B.

It should just be epicgames.com but I will check with our Portal team to be sure. We’ll post back asap.

That domain produces a 404 error. I’ve tried epicgames.com and still it stalls. Do I have to open a port on the firewall to enable a new rule for traffic coming in from your servers?

I don’t think you’ll need to open a port but I will talk with the developers and try and get some information on your issue.

-Max B.

Don’t worry about the 404 error on download.epicgames.com … in fact that’s good news, as it means you’re connecting to the website successfully. We just don’t have a web page that’s served at the root of that domain, so it gives you a not found error which is expected.
Can you confirm that you’re closing the launcher before getting your log file … what you’ve sent us seems to be incomplete, indicating that the launcher could still be running.

Hi Collingwood,

We haven’t heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you’re still experiencing this issue, please respond to Yeurch above and we will continue troubleshooting the issue.