Download

Tech Note: Installed Build Generation Fails with Visual Studio 2017 in 4.26.0

Jan 20, 2021.Knowledge

Description:

The 4.26.0 release fails to create an installed build correctly if you only have VS2017 installed. This is due to a warning that occurs in VS2017, but not VS2019, which is treated as an error in the installed build generation, causing the failure. The warning is due to some compilers ( IE: VS2017 ) not correctly picking up a PRAGMA_… definition in EditorEngine.h and a few other files, unless they’re at file scope.

Potential Impact:

Moderate: This will affect anyone on 4.26.0 trying to generate an installed build through BuildGraph with only VS2017 and its toolchains installed.

Solution:

This should be fixed as of 4.26.1, but if you need it before that, the fixes are in //UE4/Release-4.26/ stream. Integrating CL 15004310 followed by 15015879 addresses the warning that’s generated.

UE VERSION

4.26